TP-Link CPE510 v3.2 bricked

Hello, after using OpenWrt on my outside AP, i have to conclusion, that stock firmware is probably better for me. After flashing back to stock firmware, my AP bricked. I have installed version for V3.0, on my 3.2, which could be probably also a probem, but every functions worked great. After trying to do flash while holding the reset button, the AP asked for vmlinuz, which i gave it via TFTP from CPE210, that should be the same as i read on OpenWRT page about this AP. After that i coudlnt move any further. On next try it was still asking for vmlinuz it was still the same. Could you please tell me where i could possibly make a mistake? Or what should i do?

Thank you for your responses. :slight_smile:

Have you tried to follow the debricking instructions on the device page?

You should use the stock firmware from the tp link website for the 510 3.2

yes, i have tried, after tracking packets it dont want to recovery.bin but vmlinuz

Can you provide it recovery.bin as instructed with the stock firmware and see what happens please?

already tried it and still the same, recovery.bin and vmlinuz are both on my tftp server and its only pulling vmlinuz

Try Downloading the intramfs version of the software and rename it to vmlinux and using that when asked for vmlinuz

That should get you to a point where it will boot up.
You can then get OpenWrt running again by connecting to the device with ssh
and running sysupgrade -F -v -n /tmp/filename.bin after uploading a sysupgrade image.

There are extra instructions for the vmlinuz issue, have you looked at this?

thank you, i try this when i come home

yeah ive tried it

guys, you are live savers, i managed to get it back to stock firmware with help of @apcameron. I owe you a beer. thank you one more time. :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.