Tp link archer c7 v5 back to stock firmware

I am running lede but i wanna go back to my tp link router to try somthng

Ive dowooaded the file from tp link website
But i cannot revert back to my original firmware

I have previously done this on another older tp link router in the past
I put ip adress 192.168.0.66 into my pc
Im using ftp to connect to router
I press reset button and power off at same time
I forgot to say i renamed file to what was recomended
The ftp recogines the file it loads for a few seconds then it times out
And im still on lede fw
Any help would be great

Did you follow this guide?
https://openwrt.org/docs/guide-user/troubleshooting/tftpserver

Look at this thread:

Maybe use the WinAgents tftp server. This worked for me.
https://www.tftp-server.com/tftp-download.html

Thank you for the links
Im just about to read all the guides to see what i missed and im doing wrong

The factory firmware may include a copy of a bootloader (if it has "boot" in the name) that would need to be stripped off. Actually if you strip enough off you can flash the firmware through OpenWrt like a sysupgrade. Exactly how to do this depends on the exact firmware. There may still be a third-party site holding stripped stock firmware for some models.

i dont know how to strip the file
heres what the error message i get

Connection received from 192.168.0.86 on port 1681 [15/05 14:29:34.344]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [15/05 14:29:34.344]
File <ArcherC7v5_tp_recovery.bin> : error 2 in system call CreateFile The system cannot find the file specified. [15/05 14:29:34.344]
Connection received from 192.168.0.86 on port 2120 [15/05 14:36:13.960]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [15/05 14:36:13.960]
OACK: <timeout=5,> [15/05 14:36:13.960]
Using local port 54733 [15/05 14:36:13.960]
TIMEOUT waiting for Ack block #27715 [15/05 14:36:48.962]
using tftpd64

It looks like the second transfer went for 27000 blocks, which might be the whole file. That is odd because the first one suggests the file did not exist on the server.

What region is your router (US, EU, etc) and post a link to the TP-Link firmware you're trying to use and I will look at the file.

mk24 heres a link to what i downloaded

on my router i cant see the region is a lot of the wring to small for me to read
but i bought it from currys thats a shop in england
england is where i live
i bouught it i december 2019

i think i know what i done wrong i downloaded the oler firmware from 2018
i think
i didnt relise there was two fw on the web page untill just now

i will try the newer fw and report back cheers for the help

i just tried again i get error message again
here link

Connection received from 192.168.0.86 on port 2150 [16/05 10:25:39.126]
Read request for file <ArcherC7v5_tp_recovery.bin>. Mode octet [16/05 10:25:39.126]
OACK: <timeout=5,> [16/05 10:25:39.126]
Using local port 51428 [16/05 10:25:39.126]
TIMEOUT waiting for Ack block #29370 [16/05 10:26:14.129]

I thought i would bump this topic as i think i might made it confusing
When i edited last message
I stll cant get it to work
In my ladt post it shows the error message i get with the nwwer fw file
I hope this message might cleat up the the confusion
So all help welcomed
So i tried using the newer fw because last time i had downloaded the lldrr fw
But i still cabt revert back to orinal fw
Mk24 The link was in my last post on the fw im trying to use
Im from england and i bought my router in england
In decmber 2019 fronm a shop called currys.co.uk

Hi mate how is it going?
I have the same router (c7 v5). I was thinking could try get out the boot with this tool https://freifunk-firmware.de/bootcut.php and then get the firmware and use it via web (in open wrt) to get back to Stock firmware (TP-link). What do you think? Is it will work?
Thanks

I also have the same problem-did you fixed it in the meantime?
was the "freifunk" tool helpful to you-if yes wich bootloadersize did you use?

Did you manage to revert it back to stock?