TP-Link Archer C7 V2 [Latest patches and gcc]

Running on Breed Bootloader(kmod-mtd-rw included with builds) Breed Bootloader also has the option of flashing images in case something happens.(If you have issues with your router not booting after updating frequency settings, rather than pressing restart on the user interface for breed, just unplug the router and it boots normally with your applied settings)

GCC 7.3 \ binutils 2.30 builds

Latest Build

Latest Build

Extras

Script to Automake image and apply patches:

#!/bin/bash
git clone https://git.openwrt.org/openwrt/openwrt.git lede
#copies patches to lede directory, assuming you already have patches directory available.
cp -r patches /path/to/lede
cd lede
./scripts/feeds update -a
./scripts/feeds install -a
#applies patches and moves to appropriate directory
for i in patches/*.patch; do patch -p1 < $i; done 
mv ./target/linux/generic/patches-4.9/* ./target/linux/generic/pending-4.9/
rm -rf ./target/linux/generic/patches-4.9
#copies my config.seed file( i have saved) to the lede directory as .config, so when i run make menuconfig in the lede directory, it already has my previous settings.
cp /path/to/config.seed /path/to/lede/.conf
make menuconfig
make -j1 V=s

if you have any questions feel free to ask, or any input on other optimizations or wrappers like libremesh,also take a look at:
(this is where i got most of my patches and experience from.)
[GCC 7.2 BUILD] Optimized TP-Link Archer C7 V2 AC1750 LEDE Firmware
this is instructions for breed:(if kmod-mtd-rw installed)
[Solved] Archer C7 V2.0 Overclock

If you see any improvements i can make let me know.

check out these firmwares based off of lede.
http://ofmodemsandmen.com/firmware.html
https://github.com/infinitnet/lede-ar71xx-optimized-archer-c7-v2

1 Like

Hi @sycohexor,

Are your builds overclocked by default? Or we must change something to overclock it?

Thanks a lot,

you havent used the breed bootloader yet?

No my friend.

ok so you need help installing it? or do you plan on installing it?

I'm testing your firmware! I want to overclock, Can you add mtd?
Regards,

So I'm lost. Your iperf tests are saying about 10Mb/s yet your Speedtest.net result is 100Mb/s?

I'll test it this weekend.

What OC are you using? Does the router heat up much with OC?

no doesnt get that hot, but its probably wise to keep it out in the open obviously or near a fan if you have one, i have a bread board with a power supply to it, running an old computer fan(just put the router on top of the fan) blowing air into it. @ezar ill include it on the next one. @Gigabit iperf is a raspberry pi zero arm v7 to the router, and it was streaming a camera at the time as well, the other is external to speedtest.net, just my basic 100 mpbs speed connection from a laptop.

1 Like

Thank you!

ok i added the kmod-mtd-rw to the stack, so far its on the dhcpforward, ill have the dhcp one uploaded in a couple hours.

1 Like

so how is it running? has anyone else tested it?

im gonna throw this in there! rather than tcpdump mini

https://github.com/mwarning/device-observatory

So,
can I flash sysupgrade.bin directly from Root's version of LEDE in browser?
And then flash Breed?

What's the password, if any.

if @r00t has the kernel module as stated above then yes, otherwise download the generic or my last upload with the kernel module. follow these instructions:

Sorry, I was talking about installing your LEDE directly form root's?

And what's the difference between DhcpDnsForward and DhcpDns?

My Archer C7 v2 is overclocked:

[0.000000] Clocks: CPU:1000.000MHz, DDR:760.000MHz, AHB:380.000MHz, Ref:40.000MHz
[0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 3822520893 ns
[0.000005] sched_clock: 32 bits at 500MHz, resolution 2ns, wraps every 4294967295ns
[0.008512] Calibrating delay loop... 498.89 BogoMIPS (lpj=2494464)

No heat, no hangs, no hardware modifications.... and working like a charm.

1 Like

the difference between the two is in the read me file, one is meant only for dhcp forwarding to another device hosting a dhcp server and dns, the other has a local dhcp server and dns package already built into the binary.

mine still onlly says 720 mhz on the kernel log, idk what my issue is

@Klingon, Do you overclock using @sycohexor latest firmware?
Regards,