TP Link Archer C7 Issues with OpenWrt?

Hey Forum,

I once again come to you, hat in hand.

I am having enormous issues trying to get OpenWRT working on my Archer C7 v5 routers. This post may be long, but I will try to info dump as much as I can to help diagnose the issue and hopefully show I am not a total n00b.

I just moved into a house and I have my main router (Linksys EA8300 with OpenWRT 19) in the basement by the modem. I get OK signal strength throughout the house (3 floors) but it is already wired for Ethernet to several rooms and I figured I should add some AP's to improve quality throughout the house.

I bought this router (2 in fact!) because it was one of the cheapest routers on the Table of Hardware which supports new versions of OpenWRT. My use case is using it in the Dumb AP configuration.

I followed the dumb ap guide, with some slight adjustments because I use the 10.0.0.0/8 for my home network and I use VLAN's. So essentially, my configuration is the base firmware (22.03) + dump ap guide + a little manual tweaking of the /etc/config/network file to get things exactly right. The tweaking mostly follows the solution found in this forum post where they had similar issues.

My issues so far:

  1. Following the dumb AP guide as-is does not work. Something about the new OpenWRT 22 LUCI setup/config, the interface is not br-lan, just lan. When I plug the switch into the home network, I can access the router via IP, but it does not bridge WLAN with LAN by default. I have to tweak /etc/config/network to bridge everything properly, which then lets the WIFI network work as it should (hand out DHCP correctly, advertise DNS).

  2. The WIFI sucks. Not the wifi speed or signal, but the WLAN interfaces themselves fight me at every turn. Sometimes I change the BSSID and the interface just wont start. On the A/C/N interface, I have to use channel:auto or a channel below 48, or the interface just wont start. I was trying to do some debugging on the system, and at one point, the A/C/N device just disappeared!

  3. Clients wont stay associated. This really punched me in the gut. I spent hours trying to get this device configured like I wanted, probably 3-4 fresh installs and I thought I finally got it all working. Can connect my phone over wifi, pulled up a youtube video, everything is great. Then, 5-10 minutes later, my phone just drops the connection and wont re-associate. It presents as though it cant get a DHCP reservation. This has happened on my phone and laptops, so I know its not a client issue.

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key '*********'
	option ssid '**********'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option key '*********'
option ssid '**********'

etc/config/network

config interface 'loopback'	
        option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix  '************'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'
	list ports 'eth0.20'
	list ports 'wlan0'
	list ports 'wlan1'

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '10.0.20.1'
	list dns '10.0.20.1'
	option device 'br-lan'
	option ipaddr '10.0.20.8'

config device
	option name 'eth0.2'
	option macaddr '84:d8:1b:7b:e9:c4'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0t'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '20'
	option description 'HOME'
	option ports '0t 2 3 4 5'

I feel there is a 25% chance this is my fault and I am just overlooking some simple detail that would fix all of this.

So tell me forum, what am I missing? Should I try a different version of OpenWRT (perhaps 20 or 21)? Is there a particular package I should ugrade? Am I missing a particular toggle or line in an obscure menu or config.

Any help is appreciated. I am willing to do a little more work, but I have sunk way too many hours into this already and Im thinking to just buy a nicer router or access point solution.

I use ArcherC7 for a long time with many different version of OpenWRT.

My current version is:

root@tplink-ArcherC7:/# ubus call system board
{
        "kernel": "5.10.176",
        "hostname": "tplink-ArcherC7",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "TP-Link Archer C7 v5",
        "board_name": "tplink,archer-c7-v5",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.5",
                "revision": "r20134-5f15225c1e",
                "target": "ath79/generic",
                "description": "OpenWrt 22.03.5 r20134-5f15225c1e"
        }
}

I think your problem may be WiFi instability.

Actually i have few clients (OpenWRT sta client) connected to ArcherC7
and if i keep htmode 'VHT80' the connection freeze after few minutes.

Try to change /etc/config/wireless radio0 to option htmode 'VHT40' or 'HT40', that's fix all problem for me.

If you are looking for low cost AP to replace ArcherC7, i have ASUS RT-AX53U and it work very well with OpenWRT.

JC

Your bridging is incorrect. wlan hardware is not specified in the network file... in the wireless file, you specifiy the network to which you want to connect an SSID. VLANs should also not be together in a bridge. And then your switch config is also incorrect.

I also only see one SSID created in your config, yet what appears to be 2 netowkrs (VLANs 1 and 20).

So, before going into the specifics of how to fix your conifguraiton... do you have two VLANs, or is your network a single subnet? (I'm trying to understand why you have vlan1 which isn't actually connected to any physical ports, and then vlan20 which is untagged on the 4 lan ports).

EDIT: I'm realizing that this is a really old post. @ouifi - if you need help, please respond and we can hopefully address some of the issues. But given the age of the post, hopefully you figured stuff out already.

probably unrelated, but is the eth0.2 a typo?