Tp-Link Archer C60 "broken"

A few days ago I was trying to install a compilation of my own with WiFi configuration files, DHCP and if I remember correctly I also mentioned network in this thread. The problem is that apparently the router does not find the firmware (I guess) and is in an infinite loop of restarts. I would not know how to solve it.

TFTP re-flash, or serial console (there are apparently at least two C60s, so I can't link you directions).

I already tried TFTP but does not want to receive the firmware. I have version 1. I never opened it nor do I know where the serial port pins are. I have this adapter and I do not know if it works.

C60 v1 or v2?

I have version 1.

I hesitate to comment on suitability of "generic" devices, but that it shows "3V3" suggests that it can be compatible with 3.3 V logic. Confirm with a DMM prior to connecting. It may need a jumper or solder-bridge to set up properly.

Don't connect either "3V3" or "+5V" to the router, just "RXD", "TXD" and "GND".

1 Like

Yes, it is compatible with 3.3v and 5v as well.
Would I have to make a bridge on the router? I do not know how to open it and not break the plastic.

¿Cuál sería los pines que debo usar del router?

As for opening the router, you could check some videos on YouTube (or the likes) for opening your router or a similar model.

As for where to connect the wires, it should be here
Which to which? The page below shows you. It's actually for C60 V2, but a quick look suggests they have similar connection. Though, I recommend that you double check the board and the markings to make sure it's the same. You don't want to physically damage the router.

The photo in the page shows the board with populated header. Yours will not be populated. If you are not good with soldering, you could use jumpers like in the image below, or similar (or you could connect thin phone wires to the serial adapter using old computer jumpers. This will not give you the most solid connection, so you will have to play with it a bit. Also make sure the router doesn't move.

You should note that for serial connection you connect RX to TX and similarly TX to RX.

I do not know what the TX, RX and GND are. I have a soldering iron and I can connect some cables.

The router page on the Wiki, mentioned in my previous post clearly shows you which is which.

If you can avoid soldering, it's safer. If you do it, o it carefully as excessive heat could affect some components.

You only needed to scroll a bit to find it

I did not see why the images were not loaded.
So I only connect those three pins?
What method do I use later?
I saw more or less that you have to send some commands, but is not there one that does everything automatically?

You will need a TFTP software and an SSH terminal.

As for the exact commands, I'm not familiar with this particular router. But there is no such thing as automatic. You have to tell it what you want to do.

Before we go into serial, did you try this method

I already tried and it does not work. It restarts without interruption. I have TFTPD and Putty.

1 Like

The link below shows the procedure of Recovery using serial connection for Archer C7.

I would expect you need to follow a similar procedure, except the resistance thing, probably, but you need to find the addresses to use for your model, as these differ from a flash layout to another. Do some search to see if you can find this info, or wait maybe someone will have this info. I'm not there yet.

I am already connected to the router but I do not know what commands to put or what I have to do.

Does it boot all the way into OpenWrt? In that case you might be able to just hit return to get a prompt then run firstboot to reset to default settings.

If it reboots over and over again you need to access the u-boot console and tftp a good firmware to RAM, then erase the relevant area of flash and finally copy the firmware to flash.

I do not see anything that OpenWrt says. I'm in U-Boot but I do not know what command to put.

From a different device:

Hit any key to stop autoboot:  0 
(IPQ40xx) # help
?       - alias for 'help'
base    - print or set address offset

Anything in your list looking appropriate for TFTP?

It is nearly impossible to know every device, so unless there are instructions on the wiki, you'll have to help people help you.