TP-Link Archer C6 v3 - WiFI 2.4Ghz low power

I'm solving a problem with a TP-Link Archer C6 v3 (3.20) router.

Specifically with wifi 2.4 Ghz ( MediaTek MT7603E 802.11bgn )
Where it has a worse signal than 5 Ghz.

MediaTek MT7603E 802.11bgn
Channel: 6 (2.437 GHz)
Existing performance: 20 dBm

Model TP-Link Archer C6 v3
Architecture MediaTek MT7621 ver:1 eco:3
Target Platform ramips/mt7621
OpenWrt firmware version 22.03.1 r19777-2853b6d652 / LuCI openwrt-22.03 branch git-22.245.77528-487e58a
Kernel version 5.10.146

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2g'
	option cell_density '0'
	option htmode 'HT20'
	option channel '6'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'ssid'
	option encryption 'psk2+ccmp'
	option key 'MYPASSWD'

Where is my error ? Why does it have so little performance

Add this to the options for radio0:

option country 'Your CountryCode here'

The device may use least transmission power due to missing country setting. See also

For 2.4 GHz, it is 100mW for almost all countries ( see power limits per country).

Possibly not setting a country code may cause a lower limit… although 20 dBm seems nominal.

Other possible causes that come to mind:

  • interference / SNR
  • antenna performance
1 Like