TP-Link Archer C6 v2 (US) WAN interface (eth0.2) cannot be detected after installing OpenWrt

Hi,

I'm just new a new user for Openwrt.

I have a router TP-Link Archer C6 v2 (US). I tried to install openwrt but upon the installation my wan interface cannot get IP. I can see from logread the it can detect my wan interface (port 1) but I cannot get in to the internet. I verified that the router was working fine before installing openwrt.

Here are the logs and wan interface status (which I'm not seeing up). It also seems eth0.2 is not detected.

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 1C:3B:F3:7E:83:61  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::1e3b:f3ff:fe7e:8361/64 Scope:Link
          inet6 addr: fd3b:e257:3bb0::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1575 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1206 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:113700 (111.0 KiB)  TX bytes:141731 (138.4 KiB)

eth0      Link encap:Ethernet  HWaddr 1C:3B:F3:7E:83:61  
          inet6 addr: fe80::1e3b:f3ff:fe7e:8361/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1647 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1236 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:149847 (146.3 KiB)  TX bytes:151414 (147.8 KiB)
          Interrupt:4 

eth0.1    Link encap:Ethernet  HWaddr 1C:3B:F3:7E:83:61  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1575 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1204 errors:0 dropped:2 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:113700 (111.0 KiB)  TX bytes:141471 (138.1 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:193 errors:0 dropped:0 overruns:0 frame:0
          TX packets:193 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:15052 (14.6 KiB)  TX bytes:15052 (14.6 KiB)
root@OpenWrt:~# logread
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.000000] Linux version 5.4.75 (builder@buildhost) (gcc version 8.4.0 (OpenWrt GCC 8.4.0 r14926-41b867165d)) #0 Thu Nov 12 17:21:55 2020
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] printk: bootconsole [early0] enabled
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] MIPS: machine is TP-Link Archer C6 v2 (US) / A6 v2 (US/TW)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] SoC: Qualcomm Atheros QCA956X ver 1 rev 0
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Initrd not found or empty - disabling initrd
Thu Nov 12 17:22:06 2020 kern.warn kernel: [    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Thu Nov 12 17:22:06 2020 kern.warn kernel: [    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Zone ranges:
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Movable zone start for each node
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Early memory node ranges
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
Thu Nov 12 17:22:06 2020 kern.debug kernel: [    0.000000] On node 0 totalpages: 32768
Thu Nov 12 17:22:06 2020 kern.debug kernel: [    0.000000]   Normal zone: 288 pages used for memmap
Thu Nov 12 17:22:06 2020 kern.debug kernel: [    0.000000]   Normal zone: 0 pages reserved
Thu Nov 12 17:22:06 2020 kern.debug kernel: [    0.000000]   Normal zone: 32768 pages, LIFO batch:7
Thu Nov 12 17:22:06 2020 kern.debug kernel: [    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
Thu Nov 12 17:22:06 2020 kern.debug kernel: [    0.000000] pcpu-alloc: [0] 0
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32480
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Writing ErrCtl register=00000000
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Readback ErrCtl register=00000000
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] Memory: 121800K/131072K available (5139K kernel code, 193K rwdata, 1172K rodata, 1232K init, 205K bss, 9272K reserved, 0K cma-reserved)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] NR_IRQS: 51
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.000000] random: get_random_bytes called from start_kernel+0x32c/0x520 with crng_init=0
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] CPU clock: 775.000 MHz
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4932285024 ns
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.000007] sched_clock: 32 bits at 387MHz, resolution 2ns, wraps every 5541893118ns
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.008229] Calibrating delay loop... 385.02 BogoMIPS (lpj=770048)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.046721] pid_max: default: 32768 minimum: 301
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.051733] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.059452] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.071540] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.081862] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.089157] pinctrl core: initialized pinctrl subsystem
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.097070] NET: Registered protocol family 16
Thu Nov 12 17:22:06 2020 kern.warn kernel: [    0.128394] workqueue: max_active 576 requested for napi_workq is out of range, clamping between 1 and 512
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.141928] clocksource: Switched to clocksource MIPS
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.148409] NET: Registered protocol family 2
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.153857] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.162748] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.170847] TCP bind hash table entries: 1024 (order: 0, 4096 bytes, linear)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.178289] TCP: Hash tables configured (established 1024 bind 1024)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.185115] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.192060] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.199715] NET: Registered protocol family 1
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.204363] PCI: CLS 0 bytes, default 32
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.212091] workingset: timestamp_bits=14 max_order=15 bucket_order=1
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.224988] squashfs: version 4.0 (2009/01/31) Phillip Lougher
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.231181] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.254243] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.265459] pinctrl-single 1804002c.pinmux: 544 pins, size 68
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.272537] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.281354] printk: console [ttyS0] disabled
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.285955] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 9, base_baud = 1562500) is a 16550A
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.295057] printk: console [ttyS0] enabled
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.304115] printk: bootconsole [early0] disabled
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.332333] spi-nor spi0.0: w25q128 (16384 Kbytes)
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.337356] 6 fixed-partitions partitions found on MTD device spi0.0
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.343931] Creating 6 MTD partitions on "spi0.0":
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.348907] 0x000000000000-0x000000020000 : "factory-boot"
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.355441] 0x000000020000-0x000000030000 : "info"
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.361251] 0x000000030000-0x000000050000 : "u-boot"
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.367256] 0x000000050000-0x000000fd0000 : "firmware"
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.376711] 2 uimage-fw partitions found on MTD device firmware
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.382880] Creating 2 MTD partitions on "firmware":
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.388027] 0x000000000000-0x000000210000 : "kernel"
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.394025] 0x000000210000-0x000000f80000 : "rootfs"
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.399947] mtd: device 5 (rootfs) set to be root filesystem
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.407555] 1 squashfs-split partitions found on MTD device rootfs
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.414010] 0x000000540000-0x000000f80000 : "rootfs_data"
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.420434] 0x000000fd0000-0x000000ff0000 : "tplink"
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    0.426513] 0x000000ff0000-0x000001000000 : "art"
Thu Nov 12 17:22:06 2020 kern.info kernel: [    0.434099] libphy: Fixed MDIO Bus: probed
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.086311] libphy: ag71xx_mdio: probed
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.093379] switch0: Atheros AR8337 rev. 2 switch registered on mdio.0
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    1.149920] random: fast init done
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.681431] ag71xx 19000000.eth: connected to PHY at mdio.0:00 [uid=004dd036, driver=Atheros AR8216/AR8236/AR8316]
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.692701] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: sgmii
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.699442] i2c /dev entries driver
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.705552] NET: Registered protocol family 10
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.716083] Segment Routing with IPv6
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.720023] NET: Registered protocol family 17
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.724696] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.738096] 8021q: 802.1Q VLAN Support v1.8
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.743218] PCI host bridge /ahb/pcie-controller@18250000 ranges:
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.749581]  MEM 0x0000000012000000..0x0000000013ffffff
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.754988]   IO 0x0000000000000000..0x0000000000000000
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.760552] PCI host bridge to bus 0000:00
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.764824] pci_bus 0000:00: root bus resource [mem 0x12000000-0x13ffffff]
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.771929] pci_bus 0000:00: root bus resource [io  0x0000]
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.777690] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.784705] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.792918] pci 0000:00:00.0: [168c:0056] type 00 class 0x028000
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.799181] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.806331] pci 0000:00:00.0: PME# supported from D0 D3hot
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.812895] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.819780] pci 0000:00:00.0: BAR 0: assigned [mem 0x12000000-0x121fffff 64bit]
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.828218] hctosys: unable to open rtc device (rtc0)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.838502] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.852727] Freeing unused kernel memory: 1232K
Thu Nov 12 17:22:06 2020 kern.warn kernel: [    1.857434] This architecture does not have kernel memory protection.
Thu Nov 12 17:22:06 2020 kern.info kernel: [    1.864083] Run /sbin/init as init process
Thu Nov 12 17:22:06 2020 user.info kernel: [    2.485014] init: Console is alive
Thu Nov 12 17:22:06 2020 user.info kernel: [    2.488833] init: - watchdog -
Thu Nov 12 17:22:06 2020 user.info kernel: [    3.569145] kmodloader: loading kernel modules from /etc/modules-boot.d/*
Thu Nov 12 17:22:06 2020 user.info kernel: [    3.722612] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
Thu Nov 12 17:22:06 2020 user.info kernel: [    3.740524] init: - preinit -
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    4.610970] random: jshn: uninitialized urandom read (4 bytes read)
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    4.718587] random: jshn: uninitialized urandom read (4 bytes read)
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    4.889878] random: jshn: uninitialized urandom read (4 bytes read)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    6.070191] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 4 is up
Thu Nov 12 17:22:06 2020 kern.info kernel: [    6.084327] eth0: link up (1000Mbps/Full duplex)
Thu Nov 12 17:22:06 2020 kern.info kernel: [    6.097652] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Thu Nov 12 17:22:06 2020 kern.info kernel: [    6.113581] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
Thu Nov 12 17:22:06 2020 kern.warn kernel: [    6.146475] urandom_read: 4 callbacks suppressed
Thu Nov 12 17:22:06 2020 kern.notice kernel: [    6.146482] random: procd: uninitialized urandom read (4 bytes read)
Thu Nov 12 17:22:06 2020 kern.notice kernel: [   10.395251] jffs2: notice: (550) jffs2_build_xattr_subsystem: complete building xattr subsystem, 67 of xdatum (0 unchecked, 67 orphan) and 90 of xref (18 dead, 72 orphan) found.
Thu Nov 12 17:22:06 2020 user.info kernel: [   10.412961] mount_root: overlay filesystem has not been fully initialized yet
Thu Nov 12 17:22:06 2020 user.info kernel: [   10.422620] mount_root: switching to jffs2 overlay
Thu Nov 12 17:22:06 2020 kern.warn kernel: [   10.429754] overlayfs: upper fs does not support tmpfile.
Thu Nov 12 17:22:06 2020 user.warn kernel: [   10.438676] urandom-seed: Seed file not found (/etc/urandom.seed)
Thu Nov 12 17:22:06 2020 kern.info kernel: [   10.530482] eth0: link down
Thu Nov 12 17:22:06 2020 user.info kernel: [   10.551674] procd: - early -
Thu Nov 12 17:22:06 2020 user.info kernel: [   10.554810] procd: - watchdog -
Thu Nov 12 17:22:06 2020 user.info kernel: [   11.180371] procd: - watchdog -
Thu Nov 12 17:22:06 2020 user.info kernel: [   11.183917] procd: - ubus -
Thu Nov 12 17:22:06 2020 kern.notice kernel: [   11.293040] random: ubusd: uninitialized urandom read (4 bytes read)
Thu Nov 12 17:22:06 2020 kern.notice kernel: [   11.319222] random: ubusd: uninitialized urandom read (4 bytes read)
Thu Nov 12 17:22:06 2020 user.info kernel: [   11.327332] procd: - init -
Thu Nov 12 17:22:06 2020 user.info kernel: [   12.165631] kmodloader: loading kernel modules from /etc/modules.d/*
Thu Nov 12 17:22:06 2020 kern.info kernel: [   12.382534] Loading modules backported from Linux version v5.8-0-gbcf876870b95
Thu Nov 12 17:22:06 2020 kern.info kernel: [   12.390049] Backport generated by backports.git v5.8-1-0-g79400d9e
Thu Nov 12 17:22:06 2020 kern.info kernel: [   12.451386] xt_time: kernel timezone is -0000
Thu Nov 12 17:22:06 2020 user.info kernel: [   12.535291] urngd: v1.0.2 started.
Thu Nov 12 17:22:06 2020 kern.info kernel: [   12.613944] PPP generic driver version 2.4.2
Thu Nov 12 17:22:06 2020 kern.info kernel: [   12.625975] NET: Registered protocol family 24
Thu Nov 12 17:22:06 2020 kern.info kernel: [   12.706893] ath10k 5.4 driver, optimized for CT firmware, probing pci device: 0x56.
Thu Nov 12 17:22:06 2020 kern.err kernel: [   12.714994] ath10k_mac_create, priv_size: 804  hw: (ptrval)  hw->priv: (ptrval)
Thu Nov 12 17:22:06 2020 kern.info kernel: [   12.742890] ath10k_pci 0000:00:00.0: enabling device (0000 -> 0002)
Thu Nov 12 17:22:06 2020 kern.info kernel: [   12.749713] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
Thu Nov 12 17:22:06 2020 kern.notice kernel: [   12.774887] random: crng init done
Thu Nov 12 17:22:06 2020 kern.info kernel: [   15.651674] ath10k_pci 0000:00:00.0: qca9888 hw2.0 target 0x01000000 chip_id 0x00000000 sub 0000:0000
Thu Nov 12 17:22:06 2020 kern.info kernel: [   15.661249] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
Thu Nov 12 17:22:06 2020 kern.info kernel: [   15.681357] ath10k_pci 0000:00:00.0: firmware ver 10.4b-ct-9888-fW-13-8c5b2baa2 api 5 features mfp,peer-flow-ctrl,txstatus-noack,wmi-10.x-CT,ratemask-CT,regdump-CT,txrate-CT,flush-all-CT,pingpong-CT,ch-regs-CT,nop-CT,set-special-CT,tx-rc-CT,cust-stats-CT,txrate2-CT,beacon-cb-CT,wmi-block-ack-CT,wmi-bcn-rc-CT crc32 cbf49903
Thu Nov 12 17:22:06 2020 kern.info kernel: [   16.019739] ath10k_pci 0000:00:00.0: board_file api 2 bmi_id 0:24 crc32 f228337a
Thu Nov 12 17:22:06 2020 kern.warn kernel: [   18.064739] ath10k_pci 0000:00:00.0: unsupported HTC service id: 1536
Thu Nov 12 17:22:06 2020 kern.warn kernel: [   18.075177] ath10k_pci 0000:00:00.0: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Thu Nov 12 17:22:06 2020 kern.warn kernel: [   18.082951] ath10k_pci 0000:00:00.0: msdu-desc: 2500  skid: 32
Thu Nov 12 17:22:06 2020 kern.info kernel: [   18.132852] ath10k_pci 0000:00:00.0: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Thu Nov 12 17:22:06 2020 kern.info kernel: [   18.144163] ath10k_pci 0000:00:00.0: wmi print 'free: 114572 iram: 12804 sram: 29508'
Thu Nov 12 17:22:06 2020 kern.info kernel: [   18.380074] ath10k_pci 0000:00:00.0: htt-ver 2.2 wmi-op 6 htt-op 4 cal pre-cal-file max-sta 32 raw 0 hwcrypto 1
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.463027] ath: EEPROM regdomain sanitized
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.463038] ath: EEPROM regdomain: 0x64
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.463041] ath: EEPROM indicates we should expect a direct regpair map
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.463060] ath: Country alpha2 being used: 00
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.463063] ath: Regpair used: 0x64
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.535823] ath: EEPROM regdomain sanitized
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.535834] ath: EEPROM regdomain: 0x64
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.535838] ath: EEPROM indicates we should expect a direct regpair map
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.535857] ath: Country alpha2 being used: 00
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.535860] ath: Regpair used: 0x64
Thu Nov 12 17:22:06 2020 kern.debug kernel: [   18.548168] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
Thu Nov 12 17:22:06 2020 kern.info kernel: [   18.550102] ieee80211 phy1: Atheros AR9561 Rev:0 mem=0xb8100000, irq=2
Thu Nov 12 17:22:06 2020 user.info kernel: [   18.617403] kmodloader: done loading kernel modules from /etc/modules.d/*
Thu Nov 12 17:22:06 2020 user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Thu Nov 12 17:22:06 2020 user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: Connected to system UBus
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: started, version 2.82 cachesize 150
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: DNS service limited to local subnets
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: UBus support enabled: connected to system bus
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: using only locally-known addresses for domain test
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: using only locally-known addresses for domain onion
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: using only locally-known addresses for domain localhost
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: using only locally-known addresses for domain local
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: using only locally-known addresses for domain invalid
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: using only locally-known addresses for domain bind
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: using only locally-known addresses for domain lan
Thu Nov 12 17:22:07 2020 daemon.warn dnsmasq[1357]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: read /etc/hosts - 4 addresses
Thu Nov 12 17:22:07 2020 daemon.info dnsmasq[1357]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Thu Nov 12 17:22:34 2020 authpriv.info dropbear[1423]: Not backgrounding
Thu Nov 12 17:22:36 2020 daemon.notice wpa_supplicant[1532]: Successfully initialized wpa_supplicant
Thu Nov 12 17:22:37 2020 user.notice : Added device handler type: 8021ad
Thu Nov 12 17:22:37 2020 user.notice : Added device handler type: 8021q
Thu Nov 12 17:22:37 2020 user.notice : Added device handler type: macvlan
Thu Nov 12 17:22:37 2020 user.notice : Added device handler type: veth
Thu Nov 12 17:22:37 2020 user.notice : Added device handler type: bridge
Thu Nov 12 17:22:37 2020 user.notice : Added device handler type: Network device
Thu Nov 12 17:22:37 2020 user.notice : Added device handler type: tunnel
Thu Nov 12 17:22:39 2020 daemon.notice procd: /etc/rc.d/S96led: setting up led LAN
Thu Nov 12 17:22:39 2020 daemon.notice procd: /etc/rc.d/S96led: setting up led WAN
Thu Nov 12 17:22:40 2020 kern.info kernel: [   57.442196] eth0: link up (1000Mbps/Full duplex)
Thu Nov 12 17:22:40 2020 kern.info kernel: [   57.456000] br-lan: port 1(eth0.1) entered blocking state
Thu Nov 12 17:22:40 2020 kern.info kernel: [   57.461635] br-lan: port 1(eth0.1) entered disabled state
Thu Nov 12 17:22:40 2020 kern.info kernel: [   57.467550] device eth0.1 entered promiscuous mode
Thu Nov 12 17:22:40 2020 kern.info kernel: [   57.472559] device eth0 entered promiscuous mode
Thu Nov 12 17:22:41 2020 kern.info kernel: [   57.498577] br-lan: port 1(eth0.1) entered blocking state
Thu Nov 12 17:22:41 2020 kern.info kernel: [   57.504211] br-lan: port 1(eth0.1) entered forwarding state
Thu Nov 12 17:22:41 2020 daemon.notice netifd: Interface 'lan' is enabled
Thu Nov 12 17:22:41 2020 daemon.notice netifd: Interface 'lan' is setting up now
Thu Nov 12 17:22:41 2020 daemon.debug dnsmasq[1357]: listening on br-lan(#6): 192.168.1.1 port 53
Thu Nov 12 17:22:41 2020 daemon.notice netifd: Interface 'lan' is now up
Thu Nov 12 17:22:41 2020 daemon.notice netifd: bridge 'br-lan' link is up
Thu Nov 12 17:22:41 2020 daemon.notice netifd: Interface 'lan' has link connectivity
Thu Nov 12 17:22:41 2020 daemon.notice netifd: VLAN 'eth0.1' link is up
Thu Nov 12 17:22:41 2020 daemon.debug dnsmasq[1357]: listening on lo(#1): 127.0.0.1 port 53
Thu Nov 12 17:22:41 2020 daemon.debug dnsmasq[1357]: listening on lo(#1): ::1 port 53
Thu Nov 12 17:22:41 2020 daemon.notice netifd: Interface 'loopback' is enabled
Thu Nov 12 17:22:41 2020 daemon.notice netifd: Interface 'loopback' is setting up now
Thu Nov 12 17:22:41 2020 daemon.notice netifd: Interface 'loopback' is now up
Thu Nov 12 17:22:41 2020 daemon.notice netifd: Network device 'eth0' link is up
Thu Nov 12 17:22:41 2020 daemon.notice netifd: Network device 'lo' link is up
Thu Nov 12 17:22:41 2020 daemon.notice netifd: Interface 'loopback' has link connectivity
Thu Nov 12 17:22:41 2020 user.notice firewall: Reloading firewall due to ifup of lan (br-lan)
Thu Nov 12 17:22:41 2020 kern.info kernel: [   58.446001] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Thu Nov 12 17:22:41 2020 kern.info kernel: [   58.453085] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
Thu Nov 12 17:22:42 2020 daemon.err odhcpd[1648]: Failed to send to ff02::1%lan@br-lan (Address not available)
Thu Nov 12 17:22:42 2020 daemon.info procd: - init complete -
Thu Nov 12 17:22:42 2020 daemon.info urandom_seed[2015]: Seed saved (/etc/urandom.seed)
Thu Nov 12 17:22:43 2020 daemon.debug dnsmasq[1357]: listening on br-lan(#6): fd3b:e257:3bb0::1 port 53
Thu Nov 12 17:22:43 2020 daemon.debug dnsmasq[1357]: listening on br-lan(#6): fe80::1e3b:f3ff:fe7e:8361%br-lan port 53
Thu Nov 12 17:22:43 2020 daemon.debug dnsmasq[1357]: listening on eth0(#2): fe80::1e3b:f3ff:fe7e:8361%eth0 port 53
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[1357]: exiting on receipt of SIGTERM
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: Connected to system UBus
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: started, version 2.82 cachesize 150
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: DNS service limited to local subnets
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: compile time options: IPv6 GNU-getopt no-DBus UBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack no-ipset no-auth no-DNSSEC no-ID loop-detect inotify dumpfile
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: UBus support enabled: connected to system bus
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq-dhcp[2129]: DHCP, IP range 192.168.1.100 -- 192.168.1.249, lease time 12h
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: using only locally-known addresses for domain test
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: using only locally-known addresses for domain onion
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: using only locally-known addresses for domain localhost
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: using only locally-known addresses for domain local
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: using only locally-known addresses for domain invalid
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: using only locally-known addresses for domain bind
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: using only locally-known addresses for domain lan
Thu Nov 12 17:22:46 2020 daemon.warn dnsmasq[2129]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: read /etc/hosts - 4 addresses
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq-dhcp[2129]: read /etc/ethers - 0 addresses
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: read /etc/hosts - 4 addresses
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq[2129]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Thu Nov 12 17:22:46 2020 daemon.info dnsmasq-dhcp[2129]: read /etc/ethers - 0 addresses
Thu Nov 12 17:22:58 2020 daemon.info dnsmasq[2129]: read /etc/hosts - 4 addresses
Thu Nov 12 17:22:58 2020 daemon.info dnsmasq[2129]: read /tmp/hosts/odhcpd - 0 addresses
Thu Nov 12 17:22:58 2020 daemon.info dnsmasq[2129]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Thu Nov 12 17:22:58 2020 daemon.info dnsmasq-dhcp[2129]: read /etc/ethers - 0 addresses
Thu Nov 12 17:22:59 2020 daemon.info dnsmasq[2129]: read /etc/hosts - 4 addresses
Thu Nov 12 17:22:59 2020 daemon.info dnsmasq[2129]: read /tmp/hosts/odhcpd - 1 addresses
Thu Nov 12 17:22:59 2020 daemon.info dnsmasq[2129]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Thu Nov 12 17:22:59 2020 daemon.info dnsmasq-dhcp[2129]: read /etc/ethers - 0 addresses
Thu Nov 12 17:24:35 2020 authpriv.info dropbear[2171]: Child connection from 192.168.1.66:50450
Thu Nov 12 17:24:38 2020 authpriv.notice dropbear[2171]: Auth succeeded with blank password for 'root' from 192.168.1.66:50450
Thu Nov 12 17:25:39 2020 kern.info kernel: [  235.635133] Atheros AR8216/AR8236/AR8316 mdio.0:00: Port 1 is up
root@OpenWrt:~# ifstatus wan
{
        "up": false,
        "pending": false,
        "available": false,
        "autostart": true,
        "dynamic": false,
        "proto": "dhcp",
        "device": "eth0.2",
        "data": {

        },
        "errors": [
                {
                        "subsystem": "interface",
                        "code": "NO_DEVICE"
                }
        ]
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd3b:e257:3bb0::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

This commit maybe is the cause for this problem that the WAN Port are not detected anymore. I had this same Problem with the 12 November Snapshot Build and my Archer C2600 and have to downgrade to 19.07 Snapshot atfer that.

I donĀ“t know if this problem are solved.

Fixed here.

what type of connection are you using?