TP-Link Archer C50 accidentally removed UBoot

I tried to install openWrt to a tp-link archer c50 v4 router, but I did it from the web page, which bricked my router. After I tried to flash with tftp, but i did't cut the beginning of the file, so now I think the Uboot is missing. When I power it up no leds bring up, everything is dark. I opened the case, connected a 3v3 serial usb adapter, but nothing comes from the serial. Is there any way to reisntall the firmware?

You will need a SPI chip programmer and a copy of the bootloader code, which you can extract from the factory firmware or from a working unit running OpenWrt.

Be careful to save the factory partition if it hasn't already been overwritten. The factory data is unit-specific and necessary to bring up the WiFi chips.

1 Like

Can you help, how can I save the factory partition, and extract the bootloader?

The archer c50 sells (new) for under 30 EUR, used for around 10 EUR, while the components necessary to maybe recover it (3.3V USB2serial, ch341 SPI programmer, SOIC clamp, DuPont cables and pins, soldering iron- and equipment (solder sucker, desoldering braid, tin, …) amount to more than that, leaving open the risk of damaged wireless calibration data (which would be fatal). Unless you already own most of the necessary equipment or have a real need for it beyond working on this single device, it's probably not economically viable to keep trying beyond push-button tftp recovery.

1 Like