TP Link Archer AX1500(AX10) Serial Login Help

Hello! First I understand that there is no support for the TP Link Archer AX1500(AX10) as far as openwrt is concerned due to broadcom factors but I was hoping I might find some help here since I want to play around and mod this device. I've managed to solder pins onboard and get a uart connection through putty. The problem is that the device drops me into a login shell instead of root. I've tried several tp-link login/passwd lists along with login names and the web-gui created password. It only makes you supply a password but my browser tried to save it with a user name English when I logged in. That didn't work either though.

I've noticed something weird with using admin and any passwd and just the user guest. It immediately kicks me out to the "Press enter to activate console" screen instead of telling me invalid login and letting me try again a couple of times. Is there a safe guard resetting it or something?

Even just a point in the right direction would be appreciated!

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

Thanks for the reply! So the reason there is no support here is because this is a broadcom chipset. It's running the stock tp-link firmware. I really don't know where else to ask for help, ive tried ddwrt but have gotten no responses. I was really just hoping to find some one that has possibly encountered this before as I'm new to hardware hacking.

Not that it's worth anything and has been stated before, the device is running a modified version of openwrt. I assume just as a base system.... and perhaps theres a better place to be asking these questions?

You are aware of the situation as far as it comes to potential OpenWrt support (as in, probably not going to happen - and if at all, only without wireless support), as a result most developers and other contributors avoid this hardware like the plague it is, therefore you can't expect much advice about it other than suggestions to recycle it.

1 Like