TP-LINK Archer A9 v6.x

That’s amazing I had it working for a while also.

Are you using the official OpenWRT or the developer build?

Does it get the speeds that the system is designed for?

1 Like

I still have no 2.4 with the snapshot dated 2024-07-09 07:46:54 :frowning:

2.4 radio shows as:

radio1
Generic unknown
Device is not active

I returned my Archer A9 and picked up an Archer C7 it works perfectly and its more affordable

Though it is 23.05.1, this has been working well for me:

Feel free to try out this build :+1:

Hello, It's working really well. But can you add wireguard with its gui to it please to the build? Or make it work with downloading apps?

Thanks!

cant add sqm and other packages in this build. It says, "The installed version of package kernel is not compatible, require 5.15.164-1-da89f936… while 5.15.164-1-6ec88753… is installed."
Need help please.

https://openwrt.org/faq/cannot_satisfy_dependencies

A new build is live! :rocket:

@Raven993 @ricebox You both can give it a try now. Do let me know how it works out :+1:

1 Like

I can't get the wifi speeds to work anywhere near what they were with stock firmware, was over 300Mbps, now maxing out around 70. Other than that it seems to be working fine, both bands are indeed working.

system board:

	"kernel": "5.15.164",
	"hostname": "OpenWrt",
	"system": "Qualcomm Atheros QCA550X ver 1 rev 0",
	"model": "TP-Link Archer A9 v6",
	"board_name": "tplink,archer-a9-v6",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "23.05-SNAPSHOT",
		"revision": "r24046-ed0b1db2c8",
		"target": "ath79/generic",
		"description": "OpenWrt 23.05-SNAPSHOT r24046-ed0b1db2c8"
	}
}

network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdd6:46ba:6f8e::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0.2'
	option macaddr 'REDACTED_MAC_ADRESS'

config interface 'wan'
	option device 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 0t'

wireless:


config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT20'
	option cell_density '0'
	option country 'US'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'SomeRandonNetworkName'
	option encryption 'sae-mixed'
	option key 'REDACTED'
	option wpa_disable_eapol_key_retries '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'
	option country 'US'
	option txpower '24'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'SomeRandonNetworkName'
	option encryption 'sae-mixed'
	option wpa_disable_eapol_key_retries '1'
	option key 'REDACTED'

dhcp:

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

firewall:

config defaults
	option syn_flood	1
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	ANOTHER_REDACTED_MAC
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	REDACTED_MAC
#	option src_port	80
#	option dest		wan
#	option dest_ip	REDACTED
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	REDACTED
#	option dest_port	120
#	option proto	tcp

You'll want to use 40MHz channel width, or maybe even 80MHz.

And here, you may want to consider 40MHz channels.

I receommend against using sae-mixed as there are many client devices that just don't work properly. Stick to purely WPA2 or WPA3, not mixed mode.

Upgrading to a stable release might also be a good idea.

Since firmware-selector seems down, use https://downloads.openwrt.org/releases/23.05.4/targets/ath79/generic/

Unfortunately that yielded only about 20Mbps improvement.

Tried that, but 2.4Ghz isn't supported in the stable release, which isn't worth it. Time to go back to stock I guess

Couldn't find any documentation but J2 on the board is a 3.3v serial port with pins TX, RX, GND, and 3.3V, and 115200 baud rate

80MHz works and gets me about 300mbps.
When set to 160MHz my mt7921e nic cannot find it.

I Used the online tool here - Online tool to convert TP-Link stock firmwares to sysupgrade-compatible images Then force flashed the sysupgrade image through the openwrt web UI.

any chance you could integrate the 2.4 drivers in latest 24.10.0-rc5 ? Wanted to give it a try but don't have the know how to compile myself. Your 23.04.5 one was really stable, but with reduced speed of 200 ish in a good day for 300 mbps cable connection.

it's not just compiling, the patch will not work with new kernel without changes.

I also keep getting errors with IOT devices

hostapd: phy1-ap0: AP-STA-POSSIBLE-PSK-MISMATCH

Looks like it was fixed in snapshot [https://www.reddit.com/r/openwrt/comments/1g71yk3/apstapossiblepskmismatch_cannot_properly_join_one/?utm_source=share&utm_medium=web3x&utm_name=web3xcss&utm_term=1&utm_content=share_button&rdt=36418]
but oh well