TP-Link Archer A7 v5, OpenWrt 21.02.1, 2.4 GHz Max TXPOWER only 17 dBm

Hello OpenWRT Devs,

First of all, thank you so much for making OpenWRT available for TP-Link Archer A7 v5. Everything is working good in version 21.02.1 including SQM over PPPoE WAN interface. The only issue I have is the 2.4 GHz WiFi range seems to be low for this device. Country is "India". Below is my /etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option require_mode 'n'
	option path 'platform/ahb/18100000.wmac'
	option cell_density '0'
	option htmode 'HT20'
	option beacon_int '100'
	option country 'IN'
	option txpower '20'
	option channel '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11a'
	option require_mode 'n'
	option path 'pci0000:00/0000:00:00.0'
	option cell_density '0'
	option beacon_int '100'
	option htmode 'VHT40'
	option channel '36'
	option country 'IN'
	option txpower '30'
	option disabled '1'

config wifi-iface 'wlan_2dot4ghz'
	option ifname 'wlan_2.4ghz'
	option device 'radio0'
	option network 'lan_1'
	option mode 'ap'
 	option ssid '<SSID>'
	option key '<PASSWORD>'
	option encryption 'psk2+ccmp'
	option disassoc_low_ack '0'
	option ieee80211w '1'
	option isolate '1'

config wifi-iface 'wlan_5ghz'
	option ifname 'wlan_5ghz'
	option device 'radio1'
	option network 'lan_1'
	option mode 'ap'
	option ssid '<SSID>'
	option key '<PASSWORD>'
	option encryption 'psk2+ccmp'
	option disassoc_low_ack '0'
	option ieee80211w '1'
	option isolate '1'

I have tried Channel 1, 6, 11 but the TXPOWER always seems to be set only to 17 dBm (as shown in LuCI) although India allows upto Max 20 dBm.

For comparison, I have a TP-Link TD-W9970 v4 (VDSL2 Modem Router combo) device running OEM firmware (no OpenWRT available for that device) that has better 2.4 GHz WiFi range than the Archer A7 running OpenWRT. The ISP provided ONT device (re-badged https://www.gpononu.com/dual-mode-onu/xpon-hg323rwf858464def80de3769691395.html ) also has better 2.4 GHz WiFi range compared to the Archer A7.

How do I make sure the 2.4 GHz TXPOWER is set to 20 dBm?

EDIT: WiFi Driver Channel Power details at TP-Link Archer A7 v5, OpenWrt 21.02.1, 2.4 GHz Max TXPOWER only 17 dBm - #3 by ka2107

Would you please share the output from the command iw phy phy0 channels? This should list the maximum power for all 2.4GHz channels provided by the Wifi driver.

Please note phy0 is 5 GHz radio (radio1 in my /etc/config/wireless) and phy 1 is 2.4 GHz radio (radio0 in my /etc/config/wireless).

root@ARCHER-A7:~# iw phy phy1 channels
Band 1:
	* 2412 MHz [1] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40+
	* 2417 MHz [2] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40+
	* 2422 MHz [3] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40+
	* 2427 MHz [4] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40+
	* 2432 MHz [5] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40- HT40+
	* 2437 MHz [6] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40- HT40+
	* 2442 MHz [7] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40- HT40+
	* 2447 MHz [8] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40- HT40+
	* 2452 MHz [9] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40- HT40+
	* 2457 MHz [10] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40-
	* 2462 MHz [11] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40-
	* 2467 MHz [12] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40-
	* 2472 MHz [13] 
	  Maximum TX power: 20.0 dBm
	  Channel widths: 20MHz HT40-
	* 2484 MHz [14] (disabled)
root@ARCHER-A7:~# iw phy phy0 channels
Band 2:
	* 5180 MHz [36] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40+ VHT80
	* 5200 MHz [40] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5220 MHz [44] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5240 MHz [48] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5260 MHz [52] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5280 MHz [56] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5300 MHz [60] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5320 MHz [64] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- VHT80
	* 5500 MHz [100] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40+ VHT80
	* 5520 MHz [104] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5540 MHz [108] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5560 MHz [112] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5580 MHz [116] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5600 MHz [120] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5620 MHz [124] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5640 MHz [128] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5660 MHz [132] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5680 MHz [136] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5700 MHz [140] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5720 MHz [144] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- VHT80
	* 5745 MHz [149] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40+ VHT80
	* 5765 MHz [153] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5785 MHz [157] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5805 MHz [161] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5825 MHz [165] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5845 MHz [169] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- HT40+ VHT80
	* 5865 MHz [173] 
	  Maximum TX power: 30.0 dBm
	  Channel widths: 20MHz HT40- VHT80

I have such a device and I observe the same behavior. If you change the country code to 'US', you will be able to release the full supported TX power.

However, this would be your country's Wi-Fi regulations breach, so it is up to you to decide if this information is of any use to you.

1 Like

You are right. Changing the country code to 'US' for the 2.4 GHz radio allows full 20 dBm TXPOWER. Looks like for 'US' the max allowed TXPOWER is 24 dBm which is higher than 20 dBm allowed for 'IN'. So I restricted the max txpower using 'option txpower' in the config and that seems to work.

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option require_mode 'n'
        option path 'platform/ahb/18100000.wmac'
        option cell_density '0'
        option htmode 'HT20'
        option beacon_int '100'
        option txpower '20'
        option channel '1'
        option country 'US'
root@ARCHER-A7:~# iw phy phy1 channels
Band 1:
	* 2412 MHz [1] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40+
	* 2417 MHz [2] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40+
	* 2422 MHz [3] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40+
	* 2427 MHz [4] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40+
	* 2432 MHz [5] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+
	* 2437 MHz [6] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+
	* 2442 MHz [7] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40- HT40+
	* 2447 MHz [8] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40-
	* 2452 MHz [9] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40-
	* 2457 MHz [10] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40-
	* 2462 MHz [11] 
	  Maximum TX power: 24.0 dBm
	  Channel widths: 20MHz HT40-
	* 2467 MHz [12] (disabled)
	* 2472 MHz [13] (disabled)
	* 2484 MHz [14] (disabled)
1 Like