TP-Link Archer A6 v3.0(US) Boot-Loop on WiFi Enable

I flashed my TP-Link Archer A6 v3.0 ( Link) with OpenWRT using the OEM Update page (I used the Firmware OpenWRT Install URL file in this page . The router booted and my laptop acquired IP. Then...

The moment I enabled Wireless on any band the router restarted and went onto a boot loop. With little difficulty, I did a reset logged into Luci, and enabled wireless again. The same issue, the router restarts as soon as the wireless light is turned on. I did try to install the Upgrade File from the device page but the same result.

I have not tried the snapshot version yet. Anyone who has come across a similar issue please help.

Do you have issues on 5Ghz only or any band? An issue about 5GHz is already reported here

plus workarounds.

I have seen the thread on 5GHz. The issue seems to be persisting on 2.4GHz as well. I did reset a couple of times and enabled different radios just to check. It goes into boot loop in either band. I have reverted back to OEM firmware as of now.

and did you try the workarounds ?

No, it is kind of my primary work router(near to my workstation) so I had to flash it back to stock firmware. I will try again this weekend.