Totolink X5000R ISP connection problem

Hello everyone,
I have been using OpenWRT router for a month, which is connected to my old router. The problem had appeared, when I connected it directly to my ISP. Basic research showed that the router cannot get ip from ISP (My ISP has no mac addresses whitelist. I can use any device with any mac). The reason is either ISP ignores DHCP broadcast or signal fades out in the middle. I wrote to tech support, and they replied, that problem is in my device and requests payment to solve it.
First, I had returned to stock firmware and there was no connection problem. So that is not a hardware defect. Then I had connected my laptop via udhcpc utility and there also weren't any troubles Finally, I had connected a router to my laptop to confirm there is no misconfigured firewall and tried to send a message from last device. Everything worked fine
So I can only assume that signal fades out in the middle because of OpenWRT firmware. Unfortunately, I don't know which length of twisted pair/optical fiber is needed to reproduce it.
The only solution I have is connection through another router.
By the way, I have tried to set static ip address and changed lan port to wan, but it didn't help.

Additional info:

Perhaps configure a valid, but different, MAC address on your WAN interface, just to test for the rare case of your router not having a unique MAC and your ISP stumbling over two CPEs with the same MAC.

I had tried several different MAC addresses, nothing changed.

This appears to be a rather ordinary MT7621 box so OpenWrt is well proven on that chip. What does the log say when you disconnect and reconnect the Ethernet cable to the WAN port?

I wouldn't modify anything about the MAC address, to be honest. I see no reason why this is breaking anything, especially when it comes at the cost of writing stuff with an i_want_a_brick option.

@tty: Try hooking up your laptop's ethernet port to the wan port of the router and run tcpdump on the laptop's port and verify that the router sends a proper readable DHCP request on that port.

Also the ISPs reply looks rather fishing.

13:39:33.571881 IP > BOOTP/DHCP, unknown (0x71), length 11

That's unlikely to be a valid DHCP response, despite the originator port clearly being a dhcp server. Some sort of corruption?

i_want_a_brick option is just to indicate that we should not do anything especially if we are on the bootloader
there as we do not touch mtd0 but the factory mtd2.bin

Yes length is only 11 suggests it is a rejection. Use tcpdump -vv to decode the packet.

If your MAC on the wire starts with 16: that is a valid MAC, but it has the locally administered bit set meaning it should not be in the factory table.

Ok, I've found the solution. You just need to downgrade link speed.
To do this:

opkg update
opkg install ethtool
ethtool -s wan speed 100 duplex full autoneg on

Thanks everyone for help.

I attach this cute anime girl to attract attention and describe my feelings that I experience using OpenWrt.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.