TL-WR940N v6 (US) No TFTP, No TTL,?


#1

Ok so I've given it my all on this router.
It's giving no effort to connect to a TFTP server.
Tried a few different lappys, a couple different bits of software, one that I know works because I flashed a wr841 not too long ago.
I've inspected it in wireshark, absolutely nothing coming from it, it just boots like normal.
I'm doing the only methods I've found, just hold reset and plug it in. Some say release after the light comes on, some after 5 sec, some say just hold it until the TFTP software says it transferred one.
None of these are doing anything.

SO naturally I tore it open and hooked on my usb uart based on a PL-2303 chip. I just probed before the empty pads most bridge with solder because I don't have any solder kit at work. And nothing at all here either, no serial output. I'm using the normal tplink settings, 115200, 8n1, no parity, no flow.

Getting desperate, I found a ddwrt bin I could flash from the tplink webgui. That went successfully so I then tried flashing openwrt from the ddwrt webgui, and nothing. I then tried flashing factory, also didn't work, just rebooted ddwrt.

What is wrong with this stupid router, nothing works.


#2

Past https://openwrt.org/supported_devices/432_warning you mean?

Have you confirmed that you're trying to flash the proper OpenWrt image?

TP-Link has a "habit" of not populating resistors around the serial port, so many times series resistors and/or pull-up/down resistors are needed.


#3

I haven't gotten far enough to have anywhere to even see that warning
I inspected around the serial header, and it has the resistor for each the TX and RX pulling it it to ground.


#4

Are you sure you connected them right? Tx to Rx and Rx to Tx?

Have you?


#5

Okay, I have now confirmed that my uart is colour coded incorrectly.
It now gives garbage until ddwrt boots, then good output.
Is bootup a different speed or something? I can type and browse around fine once its booted so idk if I need more resistors to ground or something. It already has one.


#6

It is possible that bootloader and the installed linux firmware use different bitrates, not very common and very inconvenient, but there are combinations that fall into this trap.


#7

Try reducing the baud rate then--this is the easiest thing to try.

57600
38400
19200
9600


#8

I ordered a 15k resistor and pulled tx to 3.3v like the documentation said, no difference.
I tried all the common baud rates with no luck either.

¯_(ツ)_/¯