TL-WR940N v6.1 kernel panic

After sysupgrade to snapshot
it become looping boot because of kernel panic when kmodloader ath9k driver

[    9.278703] Data bus error, epc == 80e03828, ra == 80e03828
[    9.284465] Oops[#1]:
[    9.286816] CPU: 0 PID: 478 Comm: 0000000 00015f18
[    9.325103] $20   : 00000007 00000004 00000004 000003ff
[    9.330533] $24   : 00000000 afe813e2          07)
[    9.368758] PrId  : 00019750 (MIPS 74Kc)
[    9.372805] Modules linked in: ath9k(+) ath9k_common pppoe ppp_async ath9nf_conntrack_rtcache nf_conntrack iptable_mangle iptable_filter ip_tables crc_ccitt compat ip6t_REJECT nf_reject_ipv6 nf_log_ip68e2079
[    9.458624]         000003e8 efdfdaae 000003ff 80e20000 81a46000 81be0010 81b99b0c 00000004
[    9.467314]        1837] [<80e1e6f4>] 0x80e1e6f4 [ath9k_hw@80e00000+0x51020]
[    9.507952] [<80e1ffb0>] 0x80e1ffb0 [ath9k_hw@80e00000+0x51020]
9.546829] [<80092d84>] 0x80092d84
[    9.550437] [<80e62448>] 0x80e62448 [ath9k@80e60000+0x15d50]
[    9.556273] [<80113c08>]a8>] 0x803a7ba8
[    9.550437] [<80e62448>] 0x80e62448 [ath9k@80e60000+0x15d50]
[    9.556273] [<80113c08>]a8>] 0x803a7ba8
[    9.593488] [<8023d66c>] 0x8023d66c
[    9.597086] [<8023b7dc>] 0x8023b7dc
[    9.600691] [<8023d5e8>] 0x0]
[    9.648412] [<80e5d018>] 0x80e5d018 [ath9k@80e60000+0x15d50]
[    9.654255] [<800609f4>] 0x800609f4
[    9.657856] [<8 0x800ca0a8
[    9.693891] [<800ca130>] 0x800ca130
[    9.697495] [<8006f2cc>] 0x8006f2cc
[    9.701096] [<801dc7d8>] 0x801dcing: Fatal exception
[    9.730383] Rebooting in 1 seconds..

i try tftp-ing all factory image from 18.06.6 18.06.7 19.07 19.07.1 and current snapshot version, still no luck.

It's (EU) varian.

Anything i could do for fixing this kernel panic ?
Thank you

Did you try to enter failsafe mode?

then sysupgrade ?

Well if you are able to enter failsafe you could as well sysupgrade a stable version.

i just can press f when booting process to enter failsafe
after showing prompt
nothing i can type on console

Then your best bet is the device page instructions.
Pay special attention to the note on this thread.

I found that my cabelling for usb uart into mod-added serial header on this board are not solid.
After i fixed all cabelling, i can type on failsafe prompt easily.

Still, after sysupgrade via failsafe mode succeed, kernel panic persist.

It turns out that if i tftp again using stock tplink, it's working fine, but no wifi at all and stock fw report can load ath9 driver.

Hi - sorry it's taken a while to respond to this. My TL-WR940N v6.1 is on 18.06.4 - r7808-ef686b7292. It's been working fine for a few months now - 24x7. Maybe you could try this version? If this still doesn't work, maybe the hardware is faulty? Let us know.

1 Like

using 18.06.4 have the same result
Data bus error, epc == 80e03828, ra == 80e03828

back to stock tplink i only can use it's wan port and lan port ether

I guess this means the hardware is faulty - I can't think of any other reason really.

@xj25vm , probably it's because of broken art partition by improper modification on dts file . Where can i have this art backup ?