TL-WR902AC V3 bricked with bad firmware upgrade, fixable?


#1

I have a TP-Link TL-WR902AC V3, I tried to upload new firmware via web gui, I might have uploaded the wrong firmware though (I was doing upgrades on many products) and now the device is blinking all LEDs. I have tried using Reset button but the device never contacts the tftp-server.
What can I be doing wrong here? Is there anything I can do to unbrick this unit?

I have tftp-server running on 192.168.0.66 exactly as the instructions from LEDE on TP-Link WR902AC v3

(I'm running LEDE on other TP-Link products without any problems.)


#2

Hm. There doesnt appear to be a device page for the v3. That could mean support for this device is still new , or could mean it never got fully polished .

https://openwrt.org/toh/start?dataflt[Model*~]=WR902AC

Edit: git commit only got merged into 18.06.0 , so yes this is a very newly supported device.

This was the also mentioned on the commit notes too:

Flash instruction:

The only way to flash LEDE image in TL-WR902AC v3 is to use
tftp recovery mode in U-Boot:

1. Configure PC with static IP 192.168.0.66/24 and tftp server.
2. Rename "openwrt-ramips-mt76x8-tplink_tl-wr902ac-v3-squashfs-tftp-recovery.bin" to "tp_recovery.bin" and place it in tftp server directory.
3. Connect PC with the LAN port, press the reset button, power up the router and keep button pressed for around 6-7 seconds, until device starts downloading the file.
4. Router will download file from server, write it to flash and reboot.