TL-WR902AC v1 - failed sysupgrades for all 19.07 stable releases

As the title states, I have had failed sysupgrades for all stable release versions of 19.07 on my TP-Link TL-WR902AC v1 travel router (ar71xx; not yet available in ath79). It is specifically the 'sysupgrade' images that appear to be problematic, as 19.07.x runs perfectly once I get a proper flash (via tftp).

Has anyone here been using either this exact device or other devices in the ar71xx target family and had similar failures (or successes)? I'm curious if this is related to the target or the specific device. And I'm wondering how we can identify the specific cause of the failure -- my current theory is that there is an issue with the 'sysupgrade' image, but that the sysupgrade functionality itself is not broken

When the device reboots after the flash process, it gets stuck in a reboot-loop of some sort (I have never connected this device via serial, so I don't know exactly what is happening, but the outward symptoms are cycling ethernet port status (plugged into my Mac, I can see the port flapping) and a blink of all the LEDs (simultaneously). I think it happens on ~4-5 second intervals. The client machine (my mac) never gets an IP via DHCP, and even if the client address is set manually in the or networks, the device does not respond to pings (I tried,,

When performing sysupgrade via LuCI, I always ensure that I do not keep settings. The file passes the SHA256 checksum (matches the downloads page checksum). I have always been careful to use the sysupgrade image tl-wr902ac-v1-squashfs-sysupgrade.bin, so I am confident that I am not causing the problem with the wrong image.

I was able to successfully use the sysupgrade process and images for every maintenance release of OpenWrt 18.06.x. However, since 19.07.0, the sysupgrade has failed every time (including from 18.06.5 > 19.07.0 which is why I don't suspect the sysupgrade functionality is broken on this device) and required tftp recovery (which has been easy and successful using the factory image). The exact same failure mode has happened for every subsequent maintenance release (19.07.1, 19.07.2, and now 19.07.3).


1 Like

Thanks for the detailed report. Can you open a bug on with this information?

More debugging (e.g. serial) would be welcome, but you can already try sysupgrading to a snapshot image and see if you can reproduce the issue.

Thanks @bjonglez.


Currently sitting at very low priority and severity low. But I would suggest those should be raised.

I think it would be very helpfull to know what exactly is going on while bootlooping.

I tested the latest snapshot sysupgrade image, and had the same problem. Factory image works properly via tftp recovery. The bug has been updated with that information.

EDIT: I tried using LuCI to go from 19.07.3 stable to the latest snapshot (not keeping settings), and after the tftp recovery, I tried the CLI sysupgrade -n process -- both failed and required the tftp recovery.

Also, I timed the boot-loop cycle, it is 10 seconds. I haven't yet had time to connect serial to try to peek into the boot loop messages.

I noticed that this device has ath79 support in the snapshot, but not 19.07.3 stable. I can try a sysupgrade to the ath79 version if it is worth it (I know ar71xx deprecated)... does anyone reading this know if we will have ath79 for this device in 19.07.4?

@bjonglez - is there anything else I should do in the near term in terms of providing more information for this bug?

Update: A bug was found in the makefile for the ar71xx file. It has been fixed (thanks Adrian!!) and should theoretically roll into 19.07.4 and higher. (I will update this thread after testing the next release).

Regarding versions 19.07.0 - 19.07.3:
Warning: Using the sysupgrade image will cause boot-looping on your device, requiring tftp recovery. Don't bother, and just jump to the solution...

Solution: Make a backup of your settings, if desired. Then download the 'factory' image and jump directly to the ttfp process, following the specifics listed in the device info page. Restore your backup, if desired after the process is complete.

Based on the discussions here and on the bug, the TL-WR902AC will only be supported using the ar71xx target for the remainder of OpenWrt 19.07.x, but will transition to the ath79 target for OpenWrt 20 and beyond (ar71xx will be entirely deprecated after 19.07). As of this writing, the ath79 target sysupgrade image (available in snapshot) works properly.

For anyone interested, see the bug report linked earlier for more info.

UPDATE 2020-Sept-10: Just updated to 19.07.4 successfully using the sysupgrade image.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.