TL-WR842N v5 Wireless is not associated

Hi. I've been using OpenWRT 19.07.3 just fine with WPA2 on my wi-fi. Yesterday saw 19.07.4, updated, and then i learned about WPA3. It looked interesting to try.
Removed wpad-basic. Installed wpad-openssl

Wireless is not associated

Then tried to install different wpad and hostapd packages - all the same. Right now i have installed wpad-basic, and still got error.
Please, let me find what exactly i broke

@ShamanInCap, welcome to the community!

I've experienced the same issue:

Thank you for your reply. Saw this commands on wiki - tried them. Sometimes got conflict of packages - removed every wpad* and hostapd* packages, rebooted, successfully installed wpad-openssl, but still got wi-fi error

I got a thougt that it might be not package, but wi-fi drivers, as WPA3 is showing in list.

Finally got it. As i thought - it was drivers. Somehow, i deleted kmod-mt76 and kmod-mt76-core. Because of that, even wifi config couldn't create right basic config. Installed, successfully created AP, choosed WPA3...

And it turns out my Redmi 5 can't work with WPA3. :rofl:

Everything was futile. But, now i know what to do if something goes wrong

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.