TL-WR841N Brick tftpd32 success but my firmware still brick

I used OpenWRT then when I flashed the Freifunk firmware I only got 20% flash then the web could only be opened partially and couldn't upgrade from the web, then I tried using TFTPD32 it always got an error, and now I managed to use TFTPD32 but my router still doesn't work and the LAN , wifi, LED all don't work

First of all, there is no "tl-wr841n" device as such, there are 14 different hardware revisions, some with vastly different hardware (SOC, wireless, etc.) - and most of them not supported by OpenWrt anymore at all (, so please clarify which device (h/w revision) we're talking about exactly.

While Freifunk and gluon are a friendly fork, their actual runtime configuration differs massively compared to 'normal' OpenWrt, so it's hard to give advice for their specifics here (and depending on your local Freifunk community the difference might be even larger).

If you really bricked your device beyond push-button tftpd's abilities for unbricking it, it might make more sense to retire this particular hardware, rather than investing money (usb2serial adapter, spi-nor flasher, soldering equipment) into unbricking it, there are (much) better devices on the second hand markets for under 10 EUR - and even brandnew good (mt7621a or filogic 820, wifi6, healthy amounts of flash and RAM) alternatives start in the 15-30 EUR range.

1 Like

So like this, I bought a used router which was actually a TL-WR842N but the shop had modified it using the TL-WR841N v11 hardware firmware and I modified it again using OpenWRT for V11.

I've tried using tftpd32 using ethernet/lan and it works but nothing changes to my router, do I really have to buy a new one? I mean it can't be fixed with just an ethernet/lan cable (no serial cable)\