TL-WR841HP v2 bricked

Hello, I have a TL-WR841HP v2.. I saw that it had similar hardware to the 941nd v6, so I installed the original tplink firmware for the 941nd v6.. It worked, then I tried putting the dd-wrt firmware from the 941nd v6 on it.. installation process followed and after it restarted it no longer works. 3 LEDs stay on and nothing else happens...

I accessed via serial to see what happened, but I didn't receive any feedback via serial.

Since you attempted using dd-wrt, you need to ask on their forums. OpenWrt is completely different than DD-WRT. Further, your device doesn't appear to be supported by OpenWrt, so you won't be using anything from the official OpenWrt project anyway.

I ask because I've seen posts here on the forums with openwrt installed on the 842hp v2

really? This specific model? My search turns up only this thread.

Can you link some threads?

That's the 841. Do you ahve an 841 or an 842?

sorry, I wrote it wrong, TL-WR841hp v2

Correcting, I have a TL-WR841HP v2, same as the post I mentioned above.

Installation instructions are in the git commit, but it looks like the prerequisite is that the vendor firmware is up and running properly. There is no mention of debricking methods on the tech data page.

And since we (OpenWrt community members) cannot know what happens when you flash the wrong DD-WRT file to a device, and how to subsequently debrick it, you'll need to visit their site for more help.


If all of the LEDs come on and don't go out, and there is no serial output, the bootloader is not running at all. A likely reason for this is that the bootloader partition in flash has been clobbered by improper flashing. To recover you'd need hardware to write directly to the flash chip and re-install the bootloader. TP-Link usually includes a copy of the bootloader in the stock firmware file-- you can break down that file and flash the bootloader only.

It's not all the LEDs, just the first three, they stay static.

Yes, that's what happened. The bootloader was corrupted, but I don't know how to extract the bootloader from the original firmware, could you help me with that?

I already bought the chip recorder...

Can you give me the dump file of TL-WR841HP v2 anything works 941nd v6 anything i just need to bring back my router by using ch341a programmer