Tl wr840n v5 bricked -- solved

Please Help,
i have flashed my TL-WR840N V5 successfully with openwrt-18.06.4-ramips-mt76x8-tl-wr840n-v5-squashfs-sysupgrade.bin without any problem , but at every reboot it loses its configuration "soft reset" so i decided to revert him back to the stock firmware.

but i finally brick it " led blinking with no SSH , telnet access" .
Now my router light is blinking try to installed via TFTP and not working its fully download firmware but after flash its starts blinking again.

Is there any ways to bring back my router to life.

SSH......... not available
telnet .......not available
TFTP without serial ........available but no result led still blinking (need for a stripped firmware )
serial connexion....... available but i dont know the memory adresses to use in those commands lines
hornet> erase...............
hornet> cp.b...................

Msg shown with putty using serial connexion



flash manufacture id: c8, device id 40 16
find flash: GD25Q32B

Ralink UBoot Version: 4.3.0.0

ASIC 7628_MP (Port5<->None)
DRAM component: 512 Mbits DDR, width 16
DRAM bus: 16 bit
Total memory: 64 MBytes
Flash component: SPI Flash
Date:Dec 11 2017 Time:16:09:07

icache: sets:512, ways:4, linesz:32 ,total:65536
dcache: sets:256, ways:4, linesz:32 ,total:32768

The CPU freq = 580 MHZ

estimate memory size =64 Mbytes
RESET MT7628 PHY!!!!!!


continue to starting system.                                                                                                                                          0
disable switch phyport...
3: System Boot system code via Flash.(0xbc020000)
do_bootm:argc=2, addr=0xbc020000
## Booting image at bc020000 ...
   Uncompressing Kernel Image ... LZMA ERROR 1 - must RESET board to recover
[04010C0E][04010D08]
DDR Calibration DQS reg = 00008887


U-Boot 1.1.3 (Dec 11 2017 - 16:09:07)

Board: Ralink APSoC DRAM:  64 MB
relocate_code Pointer at: 83fb8000
******************************
Software System Reset Occurred
******************************![Capture|527x499](upload://eHerKanzEDdyUafWoA3uxmyllBi.png)

Solved !
I finally found the stipped firmware to use
use this TFTP image :


set TFTPD to 192.168.0.66
and do a TFTP flash

sysupgrade to a compatible openwrt firmware with SSH command ,

then you had to strip the original firmware and flash it.

I get back the original firmware .:smiley:

Hope my first post will Help

TOPIC https://gist.github.com/tuyenld/fa216b146a560bca1be7569262240043

2 Likes

But you have necessary address right in your message. This looks like bc000000 is offset of memory mapped flash, and 20000 is likely offset of firmware partition, however, I'd recheck this if there were logs from a working device to find.

Booting image at bc020000 ...

I dont have much knowledge in informatics

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.