TL-WR840N V4 WiFi very weak

I had a couple of "TL-WR840N<W> V4" to integrate my Home Assistant devices and always saw that they barely passed through 2 walls and already dropped connection with some devices, measuring -94dB and such.

Today I gave my trusty old TL-WR741ND V1 with just one antenna a last go. Same place, same power supply, same channel.

To my surprise it reached all devices AT ONCE and all of them had reasonable signal strength and stopped dropping.

This leads me to believe that the MediaTek driver for OpenWRT is flawed. The 741ND uses Atheros.

TL-WR840N V4 (MediaTek - Two antennas) :

TL-WR741ND V1 (Atheros - One antenna) :

Is there any other driver available for the WR840N V4 or is this the only one?

If it is, I'll consider Atheros from now on.

have you set the region/country for your wireless?
or tried a different one.

Yes, I have tried "US", "BO" (read in other thread it should be able to do 501mW) and even "00 - World".

Selecting US it allows me 1000mW (probably just a theoretical limit, but still tried it). Then I tried 501mW. Both gave me the exact same results.

Also tried to use other channels and even tried "JP" and channel 14 which no one is on. Devices connected, but also dropped frequently.

Also tried switching between 20Mhz and 40Mhz. Made no difference.

Also tried to switch between "N" and "Legacy". No change.

Do you have the problem with all client devices or only certain IOTs?

Flash back to stock firmware to be sure that there is no hardware problem. Then this could be considered a bug.

Yep, all of them, as it seems. Even my cellphone shows mediocre signal strength when only one wall apart.
This happens with all of the TL-WR840N V4 that I have.

I can totally try that. I'll let you know.


I TFTP'd the same OpenWRT on a new V4 router and somehow, I literally can't explain this, the issue seems to have self-solved itself.
My initial idea was to perform a performance test with both stock and OpenWRT, but... yea.

Remember the "Generic 802.11bgn" appearing on the MediaTek on my first post? Well, now it's properly written "MediaTek MT76x8 802.11bgn" there.
It goes much MUCH farther now and all devices connect with similar signal strengths as the Atheros. No drops.

Also, the 501mW and 1000mW options are gone, in all countries. Now it "only" goes up to "22db (158mW)", but as I said, it goes MUCH further.

I'm not sure what happened there, but I guess the /var/config/wireless file was somehow messed up, so it used a generic driver, and a fresh flash fixed it? Or even the driver itself? But why? This makes no sense.

Anyways, I can't reproduce it for the time being.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.