(TL-WR1043ND v4) No LuCI GUI after stable release install 17.01.2

I just bought a TL-WR1043NR v4.0 for LEDE (is not my main router, I bought it for fun).
Flashed with 17.01.2.

No LuCI responding on
DHCP works well.
SSH access is available and the system looks good

I tried to start the service uhttpd but I received the error:
no sockets bound

tried to reboot it couple of times. Always ok on SSH but no Web GUI.

is my first LEDE router.

Hmm weird. I have the same model/version and for me it works just fine. LuCI however is missing in the trunk versions.

opkg update && opkg install luci

/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable

should fix this. Although I suspect you did do this. The other option is to recheck if you have a working image, stable version and reflash it.

If you want you can try my last build based on the last LEDE Reboot SNAPSHOT r4940-00e9a7aacb. If you use country code TW (Taiwan) you have available wifi channels from 2.192 GHz to 2.484 GHz.
TL-WR1043ND v4
LuCi work like a sharme.

Try a re-flash with the sysupgrade image.
Download links see ToH: Firmware download

Is TP-Link TL-WR1043NR v4.x supports LEDE? On the ToH page I just found OpenWRT for it.

LEDE 17.01.4 is available for TL-WR1043ND v4.

1 Like