TL-WDR4300 is only using/showing 4MB of its 8MB Flash?

Hello community.

I'm using a TP-Link TL-WDR4300 and installed LEDE 17.01.2 on it a few weeks ago.
Today I tried to install the OpenVPN package and got the message that there isn't enough space left on it.
So I searched a little bit about it and checked over PuTTY:

root@TL-WDR4300:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.3M      2.3M         0 100% /rom
tmpfs                    61.3M      1.1M     60.2M   2% /tmp
/dev/mtdblock3            4.4M      4.3M    100.0K  98% /overlay
overlayfs:/overlay        4.4M      4.3M    100.0K  98% /
tmpfs                   512.0K         0    512.0K   0% /dev

Clearly there isn't enough space left. I thought I have an 8MB Flash / 128MB RAM router here?!
At the same time I saw the new FW 17.01.4. So I installed the upgrade file and connected over PuTTY again:

root@TL-WDR4300:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.3M      2.3M         0 100% /rom
tmpfs                    61.3M    556.0K     60.8M   1% /tmp
/dev/mtdblock3            4.4M    304.0K      4.1M   7% /overlay
overlayfs:/overlay        4.4M    304.0K      4.1M   7% /
tmpfs                   512.0K         0    512.0K   0% /dev

Yeah, I thought! You can see the difference at Available in the line overlayfs:/overlay. There are 4.1M free like it should.
Until later I didn't realize at this time that the size didn't change to 8MB! It's still 4.4M. :man_facepalming:
So I tried to install OpenVPN again (over luci) but the site doesn't update.
I checked df -h again and was really surprised because my 4.1M free flash were suddenly gone.
Another boot, another PuTTY login but still

/dev/mtdblock3            4.4M      4.3M     56.0K  99% /overlay
overlayfs:/overlay        4.4M      4.3M     56.0K  99% /

Then I also checked dmesg for the full 8MB of flash memory. And it's there.

root@TL-WDR4300:~# dmesg | grep m25p80
[    0.608620] m25p80 spi0.0: s25fl064k (8192 Kbytes)

So I like you to give me a hint or push me in the right direction how to get LEDE to use all of the 8MB and not just 4MB.
Would be nice, thanks in advance.

This is correct, it is using all 8MB of the chip now.

The following are all stored in the flash chip.
Bootloader + ART: 192k
Compressed Kernel image : approx 1M (it is not in a file system)
root squashfs (/rom) : 2.3M
JFFS (/overlay) : 4.4M

Routers with only a 4 MB chip end up with only about 300k for the jffs.

Hello mk24.
Thanks for clearing that up! :+1: Good to know.
So I have to use the extroot config for the possibility to install some packages.
...or find some installed packages that I don't need (if there are any). :thinking: