TL-WA901ND v5 variations?


There appears to be a recent 'variation' of the TL-WA901ND v5 access point, which just boot loops after installing OpenWrt.

I have three TL-WA901ND v5 access points (confirmed v5 units)
Using the TFTP method, I am able to install OpenWrt on 1 of the 3 units.
The other 2 units, take the firmware, but then get stuck in a boot loop.
I've tried all versions of the v18 builds --- no luck.
I can revert back to the stock v5 firmware, using the TFTP method without issue. If I then try to flash OpenWrt again using the TFTP method --- it get's stuck in a boot loop.

The only difference I can see between the 1 unit that works is a 219 xxx.. series SN, vs the 2 that don't work have a 220 xxx... series SN

Any Ideas?

I'm having exact the same problem with 2 new units from the v5.
After flashing the openwrt image it boots into the bootloader but then exits as it cannot find the image.
Restore to stock firmware did work.

I tried it also with some other openwrt firmware that works on my other v5 accesspoints, but also didn't work

Often the problem is that TP-Link switched to a different flash chip which is not in OpenWrt's list of supported flash chips.

Can you connect serial to one of the non-working units, or at least look inside and read the label on the flash chip?

Thanks for your help on this. Please see pic, marking appears to be cFeon QH32B-104HIP
I hope I have the right chip here.

Yes it looks like the early production was a different chip: 25Q32CSIG.

Hi mk24 --- Any solution / suggestion to get this working with the different flash chip?

Anyone have any suggestions in getting OpenWRT to work in this TL-WA901ND v5 variant with the QH32B-104HIP flash chip?

Support for QH23B-104HIP was added in kernel v4.18. It may be simply backported into older version.
Add line

	{ "en25qh32",   INFO(0x1c7016, 0, 64 * 1024,   64, 0) },

into drivers/mtd/spi-nor/spi-nor.c and recompile firmware.