TL-WA730RE v2 64MB RAM mod

Hey guys,

I replaced my RAM with a hy5du121622DTP-D43 chip. The original was 32 MB from Zentel.

It was made by a professional with hot air gun in a factory line...

So it should be attached correctly.

Unfortunately I just see the power LED staying on and second one. No reaction...

Before I successfully upgraded the flash from 4 MB to 16 MB and also load the new boot loader from Pepe2k into my TPlink RE730v2.

Anyone knows how to proceed now?

Look at the boot loader output -- it should indicate if it recognizes the RAM at all (or may just fail completely) and, if it succeeds, what it believes the SoC can access.


Edit: As tmomas seems to hint below, a different thread on your TPlink RE730v2 may be appropriate. Thanks to tmomas for splitting thread

1 Like

What TP-Link model is this?

1 Like

https://openwrt.org/toh/tp-link/tp-link_tl-wa730re_2.0

I used own compiled images which worked fine.

In the end it worked also with MR3220 16MB images from here

I used the Mr3220 image because of the same chipsets. - it worked fine as a mr3220 with bootloader from here

I used the Mr3220 one from here

http://wiki.openwrt.org/toh/tp-link/tl-mr3420

And read old flash by hexeditor and bootloader of Pepe2k over.

Everything worked fine with the small 32 MB ram

Do you get anything on serial?

I think with these all the lights come on when power is first applied, then they go out almost instantly when the SoC starts to run. Except the power LED, because it is connected directly to the power supply rail and not controlled by a GPIO.

If you don't get anything on serial look for any activity on the SPI lines to the flash chip.

If it isn't even trying to load the bootloader out of flash it is very likely a hardware problem with the RAM. Check for adjacent pins shorted. Check for the 2.6 volt power supply, the 1.3 volt reference voltage, and the clock signals.

2 Likes

Thanks guys.

I will, but need to come home on the weekend...

Do you have a datasheet for the hynix RAM?

Google quickly returns http://www.hynix.com/product/filedata/fileDownload.do?seq=1317 and many others

Ok guys,
Serial is unfortunately not working anymore... At least I couldn't get any sign of life in screen terminal...

I messured a few different points between Vdd and Vss and messured always with my not high quality multi-voltmeter around 2,41V.

There is sometimes 2,42V and 2,40V.
Vreff to Vss is 1,21V

Is it possible to change that maybe to 2,6V?

I was also wondering if it is the right chip because in the datasheet which was referred was the first sentence 512 megabytes.

Here are some more pictures

https://www.bilder-upload.eu/bild-21eae5-1559249746.jpg.html

https://www.bilder-upload.eu/bild-fe12d1-1559249783.jpg.html

https://www.bilder-upload.eu/bild-15a3d1-1559249818.jpg.html

https://www.bilder-upload.eu/bild-c97907-1559249852.jpg.html

That is the right chip to use. 512 Mbit = 64 Mbyte. I have installed several of that exact same chip.

Part of the part number is 12 = 512 Mb, and 16 = 16 bit data bus.

The 2.6 volts comes from Q3. It is a simple PNP transistor linear regulator drawing from the +3.3 V bus. There is a circuit inside the SoC to drive the base of Q3 and regulate the voltage. It is not adjustable.

Is any part getting hot, Q3, the RAM, the SoC?

Also with the power off, put your meter on diode test and walk the leads down each side of the RAM chip testing for adjacent pins bridged together.

2 Likes

Ok, I tested it and didn't find a shortcut or similar obvious failures...

Shall I ask to reattach another of these RAM Modules or shall I just put it back and continue with another device like the popular WR841 or my WA801?

Was it possible for you guys to reattach or exchange with a normal soldering station or did all of you use the hot air caonon? - Maybe something were damaged by the hot air gun?

Hey @jeff, @tomas and @mk24,

Thanks for your support. We reattached the old 32 MB RAM, but there is still the same picture of the behavior of the RE730 v2....

I guess maybe it's unfortunately really broken during attaching the new chip via hot air gun.

Now we're struggling to proceed with my Mr3220 v2, WA801 and WR841v8.

As far as I understood, it should work to replace RAM with all of these devices, don't we?

Any suggestions how to proceed? - How did you succeed? I was also thinking about just trying by soldering, but you need to put a lot of soldering material and I get short circuit on the chip... I'm actually struggling now what to do because I let this already do from some professional people who do this already for 30 years and it unfortunately failed...

New topic please.

Suggestions for the name of the topic?

  • I mean all is related to the expanding of RAM and Flash of all 4/32 devices....

Major general questions are is there something to consider or to be aware of if you exchange the 32 MB RAM to the well known Hynix HY5DU121622DTP on any device?

In my opinion you should be able to easily exchange the RAM and the device should easily work again as before. - If I'm wrong please correct me and give me suggestions for the name of the new topics.