My QMI is not working any advise how to fix it??
## ifup wwan && logread -f
Mon Jan 9 21:29:51 2023 daemon.notice netifd: wwan (3570): Stopping network wwan
Mon Jan 9 21:29:51 2023 daemon.notice netifd: wwan (3570): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wwan" } (Permission denied)
Mon Jan 9 21:29:51 2023 daemon.notice netifd: Interface 'wwan' is now down
Mon Jan 9 21:29:51 2023 daemon.notice netifd: Interface 'wwan' is setting up now
Mon Jan 9 21:29:51 2023 daemon.notice netifd: wwan (3585): Waiting for SIM initialization
mrhaav
January 10, 2023, 8:06pm
2
Hi
I have a customized uqmi version that could solve your issues.
It´s available at: https://github.com/mrhaav/openwrt
1 Like
Hi mrhaav,
Greetings sorry for late replay. I was away in a work trip
I tried your script again, and still not working
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdd9:dfcd:675e::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option ipaddr '192.168.1.1'
config interface 'wan'
option device 'eth0.2'
option proto 'dhcp'
config interface 'wan6'
option device 'eth0.2'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'
config interface 'wwan'
option proto 'qmi'
option device '/dev/cdc-wdm0'
option autoconnect '1'
option apn 'etisalat'
option dhcp '0'
config interface 'wwan2'
option proto 'dhcp'
mrhaav
January 15, 2023, 6:22pm
4
Hi
I think you miss the authentication method. Use the Edit button and configure your WWAN.
my ISP provider has no auth, so I set it none
1 Like
mrhaav
January 15, 2023, 6:42pm
6
Yes, you need to specify option auth 'none'
.
Press Save, Save & Apply and Restart interface.
Done still Not working
config interface 'wwan'
option proto 'qmi'
option device '/dev/cdc-wdm0'
option autoconnect '1'
option apn 'etisalat'
option dhcp '0'
option auth 'none'
Try adding option pdptype
, the values are IP (for IPv4), IPV6 (for IPv6) or IPV4V6 (for dual-stack).
Both auth
and pdptype
are listed as optional in the docs though.
How to use LTE modem in QMI mode for WAN connection Some new 3G/4G dongles use qmi and mbim protocol to establish connection to ISP. For your information, qmi protocol is proprietary protocol by Qualcomm. In contrast to qmi, mbim is more...
mrhaav
January 16, 2023, 8:59am
9
Yes, option pdptype
is missing.
Try to delete your WWAN interface and re-create it with LuCI.
a-breka
January 17, 2023, 9:31am
10
It's worked thanks a lot but I lost internet connection after 6 or 7 hours. Any idea where that coming from?
mrhaav
January 17, 2023, 9:44am
11
Can you paste your syslog for modem setup and when you lost internat?
1 Like
a-breka
January 18, 2023, 8:53pm
12
QMI force me to choose Default profile is 1? Is that okay?
config interface 'WWAN'
option proto 'qmi'
option device '/dev/cdc-wdm0'
option apn 'etisalat'
option auth 'none'
option pdptype 'ipv4v6'
option default_profile '1'
Mon Jan 16 20:02:29 2023 daemon.notice netifd: WWAN (3327): Default profile: 1
a-breka
January 18, 2023, 9:25pm
13
Log of Lost connection
Mon Jan 16 22:02:46 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Wed Jan 18 22:55:42 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Wed Jan 18 22:55:42 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Wed Jan 18 22:55:42 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 1 addresses
Wed Jan 18 22:55:42 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Wed Jan 18 22:57:44 2023 daemon.info dnsmasq[1]: read /etc/hosts - 4 addresses
Wed Jan 18 22:57:44 2023 daemon.info dnsmasq[1]: read /tmp/hosts/dhcp.cfg01411c - 2 addresses
Wed Jan 18 22:57:44 2023 daemon.info dnsmasq[1]: read /tmp/hosts/odhcpd - 1 addresses
Wed Jan 18 22:57:44 2023 daemon.info dnsmasq-dhcp[1]: read /etc/ethers - 0 addresses
Wed Jan 18 22:59:54 2023 authpriv.info dropbear[2634]: Exit (root) from <192.168.1.106:65250>: Disconnect received
Wed Jan 18 23:09:23 2023 daemon.info hostapd: wlan0: STA 40:23:43:xx:xx:xx IEEE 802.11: authenticated #HERE I THINK IM NOT SURE
Wed Jan 18 23:09:23 2023 daemon.info hostapd: wlan0: STA 40:23:43:xx:xx:xx IEEE 802.11: associated (aid 1)
Wed Jan 18 23:09:23 2023 daemon.notice hostapd: wlan0: AP-STA-CONNECTED 40:23:43:xx:xx:xx
Wed Jan 18 23:09:23 2023 daemon.info hostapd: wlan0: STA 40:23:43:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Wed Jan 18 23:09:23 2023 daemon.notice hostapd: wlan0: EAPOL-4WAY-HS-COMPLETED 40:23:43:xx:xx:xx
Wed Jan 18 23:09:24 2023 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.1.112 40:23:43:xx:xx:xx
Wed Jan 18 23:09:24 2023 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.1.112 40:23:43:xx:xx:xx DESKTOP-IMDNSM2
Wed Jan 18 23:11:09 2023 authpriv.info dropbear[5560]: Child connection from 192.168.1.106:49405
Wed Jan 18 23:11:09 2023 authpriv.notice dropbear[5560]: Auth succeeded with blank password for 'root' from 192.168.1.106:49405```
AndrewZ
January 18, 2023, 9:44pm
14
The log provided has no useful information.
If you do not see in the log a driver crash or USB disconnect, then most likely you're in a common situation where the disconnect is provider initiated.
I suggest to install a package called watchcat
to monitor the connection and use a custom script to reset your modem in case of failure. Install usbutils
and use usbreset
(from that package) in your script to reset your modem.
mrhaav
January 18, 2023, 9:45pm
15
Yes, default_profile 1
is okay.
mrhaav
January 18, 2023, 9:54pm
16
Can you run logread | grep 'WWAN\|uqmi'
?
I would like to see your WWAN setup and if the uqmi daemon re-connects your internet connection.
1 Like
a-breka
January 19, 2023, 11:08am
17
root@OpenWrt:~# logread | grep 'WWAN|uqmi'
Thu Jan 19 12:41:18 2023 daemon.notice netifd: WWAN (22049): Connected with IPv4
Thu Jan 19 12:41:20 2023 daemon.notice netifd: WWAN (22049): Connected with IPv6
Thu Jan 19 12:41:20 2023 daemon.notice netifd: WWAN (22049): Setting up wwan0
Thu Jan 19 12:41:20 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:41:21 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:41:24 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:41:25 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:41:57 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:41:58 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:42:37 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:42:37 2023 daemon.notice netifd: WWAN (22511): Stopping network WWAN
Thu Jan 19 12:42:37 2023 daemon.notice netifd: WWAN (22511): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:42:37 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:42:37 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:42:48 2023 daemon.notice netifd: WWAN (22600): PINcode disabled
Thu Jan 19 12:42:48 2023 daemon.notice netifd: WWAN (22600): Data format set to raw-ip
Thu Jan 19 12:42:48 2023 daemon.notice netifd: WWAN (22600): Default profile: 1
Thu Jan 19 12:42:49 2023 daemon.notice netifd: WWAN (22600): registered on 60203
Thu Jan 19 12:42:49 2023 daemon.notice netifd: WWAN (22600): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:42:52 2023 daemon.notice netifd: WWAN (22600): Connected with IPv4
Thu Jan 19 12:42:54 2023 daemon.notice netifd: WWAN (22600): Connected with IPv6
Thu Jan 19 12:42:54 2023 daemon.notice netifd: WWAN (22600): Setting up wwan0
Thu Jan 19 12:42:54 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:42:55 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:42:58 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:42:59 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:43:31 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:43:31 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:44:05 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:44:05 2023 daemon.notice netifd: WWAN (23062): Stopping network WWAN
Thu Jan 19 12:44:06 2023 daemon.notice netifd: WWAN (23062): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:44:06 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:44:06 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:44:16 2023 daemon.notice netifd: WWAN (23151): PINcode disabled
Thu Jan 19 12:44:16 2023 daemon.notice netifd: WWAN (23151): Data format set to raw-ip
Thu Jan 19 12:44:17 2023 daemon.notice netifd: WWAN (23151): Default profile: 1
Thu Jan 19 12:44:17 2023 daemon.notice netifd: WWAN (23151): registered on 60203
Thu Jan 19 12:44:17 2023 daemon.notice netifd: WWAN (23151): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:44:20 2023 daemon.notice netifd: WWAN (23151): Connected with IPv4
Thu Jan 19 12:44:21 2023 daemon.notice netifd: WWAN (23151): Connected with IPv6
Thu Jan 19 12:44:21 2023 daemon.notice netifd: WWAN (23151): Setting up wwan0
Thu Jan 19 12:44:21 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:44:22 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:44:25 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:44:26 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:45:29 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:45:29 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:46:08 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:46:08 2023 daemon.notice netifd: WWAN (23629): Stopping network WWAN
Thu Jan 19 12:46:09 2023 daemon.notice netifd: WWAN (23629): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:46:09 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:46:09 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:46:19 2023 daemon.notice netifd: WWAN (23718): PINcode disabled
Thu Jan 19 12:46:19 2023 daemon.notice netifd: WWAN (23718): Data format set to raw-ip
Thu Jan 19 12:46:19 2023 daemon.notice netifd: WWAN (23718): Default profile: 1
Thu Jan 19 12:46:20 2023 daemon.notice netifd: WWAN (23718): registered on 60203
Thu Jan 19 12:46:20 2023 daemon.notice netifd: WWAN (23718): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:46:22 2023 daemon.notice netifd: WWAN (23718): Connected with IPv4
Thu Jan 19 12:46:24 2023 daemon.notice netifd: WWAN (23718): Connected with IPv6
Thu Jan 19 12:46:24 2023 daemon.notice netifd: WWAN (23718): Setting up wwan0
Thu Jan 19 12:46:24 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:46:25 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:46:28 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:46:29 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:47:32 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:47:32 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:47:56 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:47:56 2023 daemon.notice netifd: WWAN (24196): Stopping network WWAN
Thu Jan 19 12:47:57 2023 daemon.notice netifd: WWAN (24196): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:47:57 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:47:57 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:48:07 2023 daemon.notice netifd: WWAN (24285): PINcode disabled
Thu Jan 19 12:48:07 2023 daemon.notice netifd: WWAN (24285): Data format set to raw-ip
Thu Jan 19 12:48:08 2023 daemon.notice netifd: WWAN (24285): Default profile: 1
Thu Jan 19 12:48:08 2023 daemon.notice netifd: WWAN (24285): registered on 60203
Thu Jan 19 12:48:08 2023 daemon.notice netifd: WWAN (24285): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:48:11 2023 daemon.notice netifd: WWAN (24285): Connected with IPv4
Thu Jan 19 12:48:12 2023 daemon.notice netifd: WWAN (24285): Connected with IPv6
Thu Jan 19 12:48:12 2023 daemon.notice netifd: WWAN (24285): Setting up wwan0
Thu Jan 19 12:48:12 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:48:13 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:48:16 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:48:17 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:48:50 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:48:50 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:49:25 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:49:25 2023 daemon.notice netifd: WWAN (24747): Stopping network WWAN
Thu Jan 19 12:49:26 2023 daemon.notice netifd: WWAN (24747): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:49:26 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:49:26 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:49:36 2023 daemon.notice netifd: WWAN (24836): PINcode disabled
Thu Jan 19 12:49:36 2023 daemon.notice netifd: WWAN (24836): Data format set to raw-ip
Thu Jan 19 12:49:37 2023 daemon.notice netifd: WWAN (24836): Default profile: 1
Thu Jan 19 12:49:37 2023 daemon.notice netifd: WWAN (24836): registered on 60203
Thu Jan 19 12:49:37 2023 daemon.notice netifd: WWAN (24836): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:49:40 2023 daemon.notice netifd: WWAN (24836): Connected with IPv4
Thu Jan 19 12:49:41 2023 daemon.notice netifd: WWAN (24836): Connected with IPv6
Thu Jan 19 12:49:41 2023 daemon.notice netifd: WWAN (24836): Setting up wwan0
Thu Jan 19 12:49:42 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:49:42 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:49:45 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:49:46 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:50:50 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:50:50 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:51:14 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:51:15 2023 daemon.notice netifd: WWAN (25314): Stopping network WWAN
Thu Jan 19 12:51:15 2023 daemon.notice netifd: WWAN (25314): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:51:15 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:51:15 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:51:26 2023 daemon.notice netifd: WWAN (25403): PINcode disabled
Thu Jan 19 12:51:26 2023 daemon.notice netifd: WWAN (25403): Data format set to raw-ip
Thu Jan 19 12:51:26 2023 daemon.notice netifd: WWAN (25403): Default profile: 1
Thu Jan 19 12:51:26 2023 daemon.notice netifd: WWAN (25403): registered on 60203
Thu Jan 19 12:51:27 2023 daemon.notice netifd: WWAN (25403): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:51:29 2023 daemon.notice netifd: WWAN (25403): Connected with IPv4
Thu Jan 19 12:51:31 2023 daemon.notice netifd: WWAN (25403): Connected with IPv6
Thu Jan 19 12:51:31 2023 daemon.notice netifd: WWAN (25403): Setting up wwan0
Thu Jan 19 12:51:31 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:51:32 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:51:35 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:51:36 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:52:39 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:52:39 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:53:10 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:53:10 2023 daemon.notice netifd: WWAN (25881): Stopping network WWAN
Thu Jan 19 12:53:11 2023 daemon.notice netifd: WWAN (25881): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:53:11 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:53:11 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:53:21 2023 daemon.notice netifd: WWAN (25970): PINcode disabled
Thu Jan 19 12:53:22 2023 daemon.notice netifd: WWAN (25970): Data format set to raw-ip
Thu Jan 19 12:53:22 2023 daemon.notice netifd: WWAN (25970): Default profile: 1
Thu Jan 19 12:53:22 2023 daemon.notice netifd: WWAN (25970): registered on 60203
Thu Jan 19 12:53:22 2023 daemon.notice netifd: WWAN (25970): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:53:25 2023 daemon.notice netifd: WWAN (25970): Connected with IPv4
Thu Jan 19 12:53:27 2023 daemon.notice netifd: WWAN (25970): Connected with IPv6
Thu Jan 19 12:53:27 2023 daemon.notice netifd: WWAN (25970): Setting up wwan0
Thu Jan 19 12:53:27 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:53:28 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:53:31 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:53:32 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:54:05 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:54:05 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:54:41 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:54:41 2023 daemon.notice netifd: WWAN (26432): Stopping network WWAN
Thu Jan 19 12:54:42 2023 daemon.notice netifd: WWAN (26432): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:54:42 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:54:42 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:54:52 2023 daemon.notice netifd: WWAN (26521): PINcode disabled
Thu Jan 19 12:54:53 2023 daemon.notice netifd: WWAN (26521): Data format set to raw-ip
Thu Jan 19 12:54:53 2023 daemon.notice netifd: WWAN (26521): Default profile: 1
Thu Jan 19 12:54:53 2023 daemon.notice netifd: WWAN (26521): registered on 60203
Thu Jan 19 12:54:53 2023 daemon.notice netifd: WWAN (26521): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:54:56 2023 daemon.notice netifd: WWAN (26521): Connected with IPv4
Thu Jan 19 12:54:58 2023 daemon.notice netifd: WWAN (26521): Connected with IPv6
Thu Jan 19 12:54:58 2023 daemon.notice netifd: WWAN (26521): Setting up wwan0
Thu Jan 19 12:54:58 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:54:59 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:55:02 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:55:02 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:55:36 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:55:36 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:56:08 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:56:08 2023 daemon.notice netifd: WWAN (26983): Stopping network WWAN
Thu Jan 19 12:56:09 2023 daemon.notice netifd: WWAN (26983): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:56:09 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:56:09 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:56:19 2023 daemon.notice netifd: WWAN (27072): PINcode disabled
Thu Jan 19 12:56:20 2023 daemon.notice netifd: WWAN (27072): Data format set to raw-ip
Thu Jan 19 12:56:20 2023 daemon.notice netifd: WWAN (27072): Default profile: 1
Thu Jan 19 12:56:20 2023 daemon.notice netifd: WWAN (27072): registered on 60203
Thu Jan 19 12:56:20 2023 daemon.notice netifd: WWAN (27072): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:56:23 2023 daemon.notice netifd: WWAN (27072): Connected with IPv4
Thu Jan 19 12:56:25 2023 daemon.notice netifd: WWAN (27072): Connected with IPv6
Thu Jan 19 12:56:25 2023 daemon.notice netifd: WWAN (27072): Setting up wwan0
Thu Jan 19 12:56:25 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:56:26 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:56:29 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:56:30 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:57:03 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:57:03 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:57:37 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:57:37 2023 daemon.notice netifd: WWAN (27534): Stopping network WWAN
Thu Jan 19 12:57:38 2023 daemon.notice netifd: WWAN (27534): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:57:38 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:57:38 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:57:48 2023 daemon.notice netifd: WWAN (27623): PINcode disabled
Thu Jan 19 12:57:49 2023 daemon.notice netifd: WWAN (27623): Data format set to raw-ip
Thu Jan 19 12:57:49 2023 daemon.notice netifd: WWAN (27623): Default profile: 1
Thu Jan 19 12:57:49 2023 daemon.notice netifd: WWAN (27623): registered on 60203
Thu Jan 19 12:57:49 2023 daemon.notice netifd: WWAN (27623): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:57:52 2023 daemon.notice netifd: WWAN (27623): Connected with IPv4
Thu Jan 19 12:57:54 2023 daemon.notice netifd: WWAN (27623): Connected with IPv6
Thu Jan 19 12:57:54 2023 daemon.notice netifd: WWAN (27623): Setting up wwan0
Thu Jan 19 12:57:54 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:57:55 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:57:58 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:57:59 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 12:59:02 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 12:59:03 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 12:59:25 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 12:59:25 2023 daemon.notice netifd: WWAN (28101): Stopping network WWAN
Thu Jan 19 12:59:25 2023 daemon.notice netifd: WWAN (28101): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 12:59:25 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 12:59:25 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 12:59:36 2023 daemon.notice netifd: WWAN (28190): PINcode disabled
Thu Jan 19 12:59:36 2023 daemon.notice netifd: WWAN (28190): Data format set to raw-ip
Thu Jan 19 12:59:36 2023 daemon.notice netifd: WWAN (28190): Default profile: 1
Thu Jan 19 12:59:37 2023 daemon.notice netifd: WWAN (28190): registered on 60203
Thu Jan 19 12:59:37 2023 daemon.notice netifd: WWAN (28190): Registered to etisalat by e& on WCDMA
Thu Jan 19 12:59:39 2023 daemon.notice netifd: WWAN (28190): Connected with IPv4
Thu Jan 19 12:59:41 2023 daemon.notice netifd: WWAN (28190): Connected with IPv6
Thu Jan 19 12:59:41 2023 daemon.notice netifd: WWAN (28190): Setting up wwan0
Thu Jan 19 12:59:41 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 12:59:42 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 12:59:45 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 12:59:46 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 13:00:50 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 13:00:50 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 13:01:12 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 13:01:12 2023 daemon.notice netifd: WWAN (28668): Stopping network WWAN
Thu Jan 19 13:01:12 2023 daemon.notice netifd: WWAN (28668): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 13:01:12 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 13:01:12 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 13:01:23 2023 daemon.notice netifd: WWAN (28757): PINcode disabled
Thu Jan 19 13:01:23 2023 daemon.notice netifd: WWAN (28757): Data format set to raw-ip
Thu Jan 19 13:01:23 2023 daemon.notice netifd: WWAN (28757): Default profile: 1
Thu Jan 19 13:01:24 2023 daemon.notice netifd: WWAN (28757): registered on 60203
Thu Jan 19 13:01:24 2023 daemon.notice netifd: WWAN (28757): Registered to etisalat by e& on WCDMA
Thu Jan 19 13:01:27 2023 daemon.notice netifd: WWAN (28757): Connected with IPv4
Thu Jan 19 13:01:29 2023 daemon.notice netifd: WWAN (28757): Connected with IPv6
Thu Jan 19 13:01:29 2023 daemon.notice netifd: WWAN (28757): Setting up wwan0
Thu Jan 19 13:01:29 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 13:01:30 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 13:01:33 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 13:01:34 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
Thu Jan 19 13:02:38 2023 user.notice uqmi_d: Modem disconnected
Thu Jan 19 13:02:38 2023 daemon.notice netifd: Interface 'WWAN' has lost the connection
Thu Jan 19 13:03:12 2023 user.notice uqmi_d: Unable to re-connect IPv4 - Interface restarted
Thu Jan 19 13:03:12 2023 daemon.notice netifd: WWAN (29235): Stopping network WWAN
Thu Jan 19 13:03:13 2023 daemon.notice netifd: WWAN (29235): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "WWAN" } (Permission denied)
Thu Jan 19 13:03:13 2023 daemon.notice netifd: Interface 'WWAN' is now down
Thu Jan 19 13:03:13 2023 daemon.notice netifd: Interface 'WWAN' is setting up now
Thu Jan 19 13:03:23 2023 daemon.notice netifd: WWAN (29324): PINcode disabled
Thu Jan 19 13:03:23 2023 daemon.notice netifd: WWAN (29324): Data format set to raw-ip
Thu Jan 19 13:03:23 2023 daemon.notice netifd: WWAN (29324): Default profile: 1
Thu Jan 19 13:03:24 2023 daemon.notice netifd: WWAN (29324): registered on 60203
Thu Jan 19 13:03:24 2023 daemon.notice netifd: WWAN (29324): Registered to etisalat by e& on WCDMA
Thu Jan 19 13:03:26 2023 daemon.notice netifd: WWAN (29324): Connected with IPv4
Thu Jan 19 13:03:29 2023 daemon.notice netifd: WWAN (29324): Connected with IPv6
Thu Jan 19 13:03:29 2023 daemon.notice netifd: WWAN (29324): Setting up wwan0
Thu Jan 19 13:03:29 2023 daemon.notice netifd: Interface 'WWAN' is now up
Thu Jan 19 13:03:29 2023 user.notice firewall: Reloading firewall due to ifup of WWAN (wwan0)
Thu Jan 19 13:03:33 2023 user.notice uqmi_d: Daemon started
Thu Jan 19 13:03:33 2023 user.notice firewall: Reloading firewall due to ifupdate of WWAN (wwan0)
a-breka
January 19, 2023, 11:33am
18
AndrewZ:
package
I don't think I have enough space for all these packages
mrhaav
January 19, 2023, 11:41am
19
Kind of strange behavior.
Can you try to turn off the daemon
uci set network.WWAN.daemon=false
uci commit network
and restart the interface?
Please, paste the full syslog after the restart.
a-breka
January 19, 2023, 3:03pm
20
root@OpenWrt:~# uci set network.WWAN.daemon=false
uci: Invalid argument ### <===== LOOK HERE
root@OpenWrt:~# uci commit network
root@OpenWrt:~#