TL-MR6400 v1.0 WAN Port

Hi,

I got my hands onto TL-MR6400 v1.0 with hardware broken SIM card slot.

Friend wanted to trash it, I picked it, as I have another friend who wants simple, no frills basic wifi N.
So far I flashed OpenWRT, disabled adb-enablemodem service (no use), and removed WAN interface what was tied to usb0.
Router has 4 100M ports, LAN1, LAN2, LAN3 and LAN4/WAN.
On web interface under Network > Switch I can see 4 interfaces:

CPU (eth0),LAN 1, LAN 2, LAN 3
tagged, untagged, untagged, untagged

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'
        list ports 'eth1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 0t'
root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:DD
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24597 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39604 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3258649 (3.1 MiB)  TX bytes:35087212 (33.4 MiB)

eth0      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:DD
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24633 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39642 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3705367 (3.5 MiB)  TX bytes:35251054 (33.6 MiB)
          Interrupt:5

eth0.1    Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:DD
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:24597 errors:0 dropped:0 overruns:0 frame:0
          TX packets:39604 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3258649 (3.1 MiB)  TX bytes:35087212 (33.4 MiB)

eth1      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:E0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1055 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1055 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:80996 (79.0 KiB)  TX bytes:80996 (79.0 KiB)
root@OpenWrt:~# brctl show br-lan
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.d46e0e5a01dd       no              eth1
                                                        eth0.1

I was used to be able to reconfigure one port as WAN port, but apparently forgot something, or there is something specific with hardware for this model, I believe new VLAN was to be added, with tagging only WAN port. However then I get like a bridge configuration, I get ip from upstream server.

Any help would be much appreciated.

Hi

looks like LAN 1,2,3 are on internal switch

and eth1 (LAN4) is already standalone interface

so you should tie WAN to eth1
no need to touch anything in swconfig

Thank you @NPeca75 for response, I also assumed that and assigned eth1 to WAN to no aval.
Interface does not get assigned IP from upstream router, even when I set up interface as DHCP client.

eth1      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:E0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1480 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1561 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:237528 (231.9 KiB)  TX bytes:231071 (225.6 KiB)

LED WAN indicator is also blinking when WAN cable is connected. Once I reboot router LAN client is assigned IP from upstream router in range 10.0.0.0/24.

sorry, i don't understand this :frowning:

so, there it is
you put eth1 in br-lan
this is the problem

if you want to use ETH1 as WAN port, it could NOT be a part of LAN bridge !!!

1 Like

Indeed that was the unnoticed problem, thank you @NPeca75, for resolving this.
Configuration with eth1 removed:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 0t'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth1'
        option hostname '*'
1 Like

ok, please look at answer above your reply

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.