TL-MR3020: WLAN hidden when hot-spot not connected


I use a TL-MR3020 device in «WISP» mode. i.e. I connect the router to a hot-spot (mobile device) and other devices to the router's WLAN.

The router's WLAN accessibility seems to depend on the state of hot-spot connection:

hot-spot (mobile-yfl) disabled: WLAN (citron.brn) ist accessible
hot-spot (mobile-yfl) connected: WLAN (citron.brn) is accessible
hot-spot (mobile-yfl) not connected: WLAN (citron.brn) is NOT accessible

«not accessible» means, it does not show up in the in the list of the available WLAN of the device I want to connect too.

Thank you for any hint which resolves the problem.

The Client SSID must be connected before the Master (AP) enables. This is because your radio uses 1 channel at time.

You should be able to use the Travelmate package to overcome this.



Thank you

I tried several architectures but get always the message «incompatible with the architecture configured». Can you help me which architecture to choose?

  • Is this related to "WLAN hidden when hot-spot not connected"?
  • Are you referring to installing Travelmate?
opkg update
opkg install travelmate luci-app-travelmate

You can also install from System > Software on the web GUI.

Your screenshot shows:

(Also, feel free to ask in the Travelmate thread if this doesn't work.)

Also from:

Package architecture:

Thank you

Package architecture:

I rather used the following link. Yours a typing error?

It now connects to home WLAN and remains connected.
But it does NOT connect to a iphone hotspot. It tries several times and disables the uplink.

What is wrong

Have you verified that the iPhone hotspot works for 2.4G? If the iPhone is using a 5G radio for the hotspot, it will not work since the MR3020 only has single 2.4G radio. (I haven't checked to see if the iPhone uses both 2.4 and 5G when in hotspot mode, so I don't know the answer to this offhand).

Thank you

I found the problem meanwhile.
When the iphone hotspot is scanned through travelmate, it connects exactly once. When I disable the hotspot on the iphone an re-enable ist does not connect anymore. This is due to the changing MAC address of the iphone hotspot whenever it reconnects. I need to clear the MAC address stored the first time the hotspot connected:

Network / Wireless / (myhotspot) / Edit / Advanced Settings / MAC Address

This way the MAC address of the hotspot is retrieved every time it connects.

My travelmate on TL-MR3020 V3 device works fine now.
Thank's to all of you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.