Tips for getting cheap used x86-based firewall with full Gbit NAT (a PC Engines APU) if you are in the US

roqos has dropped to 25 us dollars on ebay completed sales, guess because of need for subscription. can you update the BIOS easily like on an apu2?

I'm running an x86_64 OpenWRT router with an SSD currently, and used essentially this approach, but went with Alpine Linux as the master/maintenance system. Installed it to a custom disk layout, booted into it, configured additional partitions, dd'd in OpenWRT to one of them, copied the kernel, then tweaked the extlinux config. Essentially the same idea; I just find syslinux/extlinux simpler than grub, and a complete rolling-release Linux distro to be a better master maintenance system than OpenWRT, and it's easier to control the boot partition size at install time.

It'd be very handy if standard release OpenWRT builds included LVM root support by default; thinpool LVM support would even better, so you don't have to use fixed-size partitions and in the latter unused space wouldn't be wasted. Not a problem if you want to build it yourself, though.

No, but I don't really see the point.

The uefi is strange, some open source solution I've never seen before - TianoCore.

I think the bios is coreboot, can't really see it during boot though, so I can't be sure.

1 Like

there are no updates for it anywhere though so they either update it automatically with the stock Linux OS, or they just don't.

Yeah the board firmware is coreboot.

TianoCore is the "upstream" UEFI firmware developed by Intel that most/all proprietary UEFI firmware are based on. https://github.com/tianocore

It's used as-is by KVM to run UEFI virtual machines and is the UEFI payload for coreboot.

Coreboot itself is not BIOS or UEFI, it's lower level hardware initialization stages. Then it can load SeaBIOS payload to provide a BIOS interface (like it does on the APUs) or TianoCore to provide UEFI interface.

Technically speaking, the same developers of the APU board firwmare have also developed a TianoCore payload for the APUs to make them UEFI but you have to compile it manually https://blog.3mdeb.com/2017/2017-11-03-uefiedk-ii-corebootpayloadpkg-on-pc-engines-apu2/
So it's possible but quite frankly has no real benefit for the types of OS you will run on an APU2 (Linux-based like OpenWrt or Debian and FreeBSD-based like pfSense/OPNSense).

3 Likes

Searching the web, I stumbled over the Velocloud EDGE 5x0 series, which seems to be based on Atom C2358 (warning, the Rangeley SOC is affected by clock signal issues) x86_64 boards. Many of these boxes seem to sell quite cheap, as the proprietary cloud backend went bust - sadly on the wrong side of the pond again.

2 Likes

12 posts were split to a new topic: OpenWrt installation on pc engines apu2c2

Hi.
Does your RC10's usb3.0 port work fine?
I grabbed one from ebey and tested it, but it seems that the usb3.0 power supply is not enough.
I tested with two USB external ssd, but both were unstable (many errors, disconnection) and in the end I extracted and installed the 500gb msata from samsung T5.

I bought this product for backup, but I wonder if it's just my problem.

Sorry, totally missed the topic swap to roqos :slight_smile:

I'll fire mine up, and check

I also only have a USB 2.0 model (even though I double tribble checked with the seller beforehand). Anyway, did you try with a stable external USB power supply?

Just got a VeloCloud EDGE 500-N. It has 4GB RAM, 64GB SSD and the Ethernet ports are all off from Marvell chips. An 88E6176 switch seems to drive the lan ports and an 88E6320 drive the 2 Internet ports and along with an 88E1112 the SFP port.

I have a backlog of equipment to catch up on but I will be eventually adding info to WikiDev for this and then loading OpenWrt.

1 Like

This is about the roqos rc10. Anyway, I tested the HDD enclosure with external power, but it doesn't connect with a bad cable blahblah message. Even if I connect another USB 3.0 stick, it does not connect with an error message. Perhaps a hardware failure.

1 Like

Can you show the contents of /proc/cpuinfo and at least the Processor Information part of dmidecode?

Sorry I have a stack of other hardware that are first on my todo list. I likely won't get to this one for over a week.

prices are so low that even with shipping costs it's a good deal for people in europe...

Shipping isn't the problem, VAT, and (if applied) customs charges, plus carrier's
"admin charges" might be.
But those vary from country to country, and carrier to carrier.

This one ended up pretty expensive - R7800 with corrupted firmware image and faulty LAN. Gosh - #76 by bright_plastik

Lesson (at least for me) is never to use the big carriers - FedEx, DHL, TNT & UPS when importing goods from outside Europe, their admin charges are very high (esp since it's a digital transaction, not touched by any human), unless the value of the parcel itself is very low.

1 Like

I tried a uSD card, it worked.

Then I tried a 2.5" 500GB HDD, it didn't even try to spin up.
So the port's either underpowered, or there's some quirk that needs to
be enabled, to get proper power to it.

A powered USB hub would probably solve the issue.

I ordered a usb tester. It will arrive tomorrow.

if it's small enough to fit in a plain or padded envelope, without any customs declaration sticker on it,
it'll probably arrive uncharged :wink:

but like i said, it also depends on where in Europe you live.

Ouch!
:heavy_check_mark: Being cited as one sad and expensive story.
Done. :sweat_smile:

I was looking into the Velocloud, they're cheap, as you said :wink:

The throughput seems very unimpressive though, if I read the specs correctly - https://assets.vonage.com/sfdc/prm/Edge_Datasheet.pdf

might be a market positioning thing though, deliberately capped by software.