OpenWrt installation on pc engines apu2c2


Has anyone tried the new release? I can't boot version 21.02.2 on my device. (BIOS v4.15.0.2)

When I check the device with RS232 serial connection, only I see the question marks after GRUB. I don't see any errors or useful information for troubleshooting.
(character encoding is fine in "SeaBIOS screen v4.15.0.2", "press F10 for changing boot priority" etc. So it's not related with baud rate.)

What have I tried so far?

  • I did file shasum verification. The image file is OK. I'm decompressing img.gz file with gunzip -k openwrt-xxxxxxxx
  • I formatted the SD card and filled it with zeros to solve possible data pollution. Then I burned the image again.
  • I tried booting from USB 2.0 stick instead of SD card.
  • BIOS reset. I cut the power of the device and took out the BIOS battery for sometime.
  • I tried different file systems. But generic-ext4-combined.img.gz and generic-squashfs-combined.img.gz gave the same result
  • 21.02.1 and 19.07.8 are OK btw.

If you have any idea please let me know!


yeah, this thread only covers one specific device ...

Sorry, I'm using SimpleWAN SW302DA also known as pc engines apu2c2, which is mentioned frequently in this topic...



since you're using a flash drive, tried booting it in some other x86 device ?

OK I'm back. Yes, the same USB stick worked on my desktop. I was able to boot into OpenWrt successfully.

Also I just upgraded BIOS few minutes ago from v4.15.0.2 (2022-01-11) to v4.15.0.3 (2022-02-16) still no luck.


have you removed the uSD card while booting the flash drive ?
there's a risk of "contamination" ....

you could also try Sysupgrade help for x86_64 - #14 by frollic as an alternative way of upgrading.

Yes, only one media is connected to the device at a time.
Thanks for the link. I will look into it.


seems weird it'd crap out when using a flash drive.

do you have a UBS uSD card reader ? try booting your current 21.02.1 using it, as you would have with your flash drive.

I agree, this looks pretty weird. I think it's obviously this specific device related since I could boot it with different PC.
Yes I have a card reader. I can flash old versions and boot without any problems. I guess I need to skip 21.02.2 for now.
Thanks for helping me!


OK I just figured out this. I was trying to boot 21.02.2 generic but on 21.02.1 I was using 64 target not the generic one. So I just need to wait for the 64 (profile?) of 21.02.2 to build. I'm sorry for taking your time.


good catch!

I was slightly confused by it too, I was looking for the plain and UEFI versions, but couldn't find them :slight_smile:

Yes! Completely my mistake. Sorry again.

Thanks for helping me. Have a good day!

it's there now :slight_smile:

1 Like