Time on overview page 4 hours ahead (logs 4 hours ahead)

So I have a fresh install of 19.07.3 on an edgerouter lite, and the local time is exactly 4 hours ahead of the time set under system=>General settings. Normally I wouldn't care about something like this but my logs are four hour ahead also, which makes it difficult to troubleshoot issues.

The timezone is set correctly, I've set it to a different timezone and then set it back to the correct one (rebooting in between just in case). I've even disabled the time daemon and synced time with browser.

Anyone one have any ideas on how to fix this or know if it's a known issue?

Thank you

edit: added pics


OK...I know what it's doing...


In recent years, I've never changed a router's time from UTC (not since version 17)...so I tested for you (we both happen to be in a UTC -4 zone right now; but I used Toronto to be sure).







Working on my OpenWrt 19.07.3 r11063-85e04e9f46 device.

Thanks for the info, unfortunately just changing timezone to UTC didn't work. When I have some time I'll do a factory reset and reconfigure without changing the timezone and see if that works.

Huh...I thought you wanted it changed it to America/Toronto?

To be clear, my demonstration showed me editing from the OpenWrt default (UTC) to your timezone (America/Toronto).


OK..this may fix it...I don't understand the theory tho...


Sorry for the confusion, or maybe I'm confused.

So you set yours to UTC-4? Correct?

The thought of the factory reset is if all else fails it may work. It doesn't take too long to setup my config, so it's not a significant investment of time.

Yes (UTC -4 is America/Toronto and others). The out-of-the-box default is UTC, I set it to America/Toronto to show you it worked.

I'm not sure why you wanna confuse things by saying "UTC -4" ,though.

Thanks for the clarification.

1 Like

It's seems there is actually something going on with the build for this device, as when I did a factory reset the time was off by four hours still between the overview page and the system properties page.

This time I was sure not to change timezone and the time disparity was present even before plugging the WAN back in.

That's what it's supposed to be, AGAIN, the default is UTC!!!


You do understand the system default is UTC; and you have to set America/Toronto, correct????

Also to be clear, the Overview Page shows router's time, and the System page shows Local time.

I'm not sure why the timezone thing is confusing you so (even after providing you a picture)...but it's hard to know, until we can confirm that you can successfully change your timezone.



Are you confused because the Overview page also says "Local Time"???

I realize now that both pages use the same label.

(Please confirm, because I think that's just a simple cosmetic bug that can get fixed easily.)

To be clear when I did a factory reset i didn't not change the time zone. It was not set to America/Toronto.

I did not know "Overview Page shows router's time, and the System page shows Local time."

The timezone between the overview and system page was the same on the last build I ran on the edgrouter lite (18.06.4). It has also been the same on the archer c7 I've run it on and it's the same on the x86 pc I've run it on (though the PC has a hardware clock).

Yes they both say "Local Time".

The problem is the kernel time (overview page) being 4 hours ahead also causes the log time to be 4 hours ahead making it difficult to analyze logs if something goes wrong.

1 Like

100% clear now.

I understood this too.

If you now proceed to change the timezone to America/Toronto...do both pages display the same time (including logs)?

(Please note, the old log entries will not magically change times...just look at new ones.)

Changing the timezone to America/Toronto still has different times on both pages, logs are still four hours ahead.

1 Like


Since I have a working 19.07.3...and you don't...hummm...


  • Make sure you press "Save & Apply"
  • I think others need to chime into this thread
  • In the meantime, you might want to check the regional and time settings on your system and browser
1 Like

mine is a bit funny too... (on snapshot) Local Time... within System page... looks like;

  • what PC/Browser is set to...
  • sync with browser does not work?
  • logs are stamped ok

( ssh > 'date' reports the right "TZ" as does overview )...

1 Like
root@OpenWrt:~# date
Mon May 25 14:58:56 GMT 2020
root@OpenWrt:~# date
Mon May 25 10:59:19 EDT 2020

Two working devices...


How are you changing the timezone?
via LuCI? editing manually /etc/config/system ???

Note that the human-readable "zonename" option visible in LuCI and config file is just user-friendliness in the default case. The actual magic comes from the "timezone" config item, which is not visible in LuCI.

As we use a simplified timezone support with the musl C library, there is usually no full zoneinfo package, but instead a POSIX style timezone string is applied. It is read from /etc/config/system file at boot and stored to /tmp/TZ file for musl.

So, if you have e.g. edited the config file by hand, and just adjusted the human-readable zonename (like America/Toronto), that does actually pretty much nothing unless you have installed the full zoneinfo package set. For most users, the key is the timezone string. (The human-readable continent/city string plays role only if the zoneinfo packages are installed)

And if that editing is done in a running system, you need to also take care of changing the /tmp/TZ file. The easiest is maybe to reboot (or to do /etc/init.d/system reload ).

LuCI has its own simple table of time zones, and changing the cleartext timezone in LuCI adjusts the TZ definitions in /etc/config/system in the background.

From my 19.07 system, adjusted for Finland.

 OpenWrt 19.07-SNAPSHOT, r11086-ab7e9754df

root@router1:~# cat /tmp/TZ

root@router1:~# head /etc/config/system

config system
        option hostname 'router1'
        option timezone 'EET-2EEST,M3.5.0/3,M10.5.0/4'
        option zonename 'Europe/Helsinki'
        option ttylogin '0'
        option log_size '64'

I see the same time in the overview page, system page and in console.
And syncing with the browser seems to work ok.


I'm changing the timezone via Luci.

When running the date command it shows:
System properties shows:


Save & Apply used.
Time settings on my system are good, just in case I'll try manually setting it later. I haven't been using sync from browser, only NTP-Server.

Thanks for your help, even though it's been frustrating for you!

I can confirm this (FB4040 19.07.3, LuCI updated just 1h ago)

  1. Timezone correctly set to Europe/Berlin
    • date: 20:05:00
    • LuCI / Status / Overview: 20:05:00
    • LuCI / System / System: 20:05:00
  2. Timezone changed in LuCI to Asia/ Bangkok, Save & Apply
    • date: 01:06:00
    • LuCI / Status / Overview: 01:06:00
    • LuCI / System / System: 20:06:00
  3. reboot
    • date: 01:07:00
    • LuCI / Status / Overview: 01:07:00
    • LuCI / System / System: 20:07:00
  4. Sync with browser
    • date: 01:08:00
    • LuCI / Status / Overview: 01:08:00
    • LuCI / System / System: 20:08:00
  5. Sync with NTP
    • date: 01:09:00
    • LuCI / Status / Overview: 01:09:00
    • LuCI / System / System: 20:09:00