Three routers one as main, second connected wireless to main, third to second

How to connect to the second router, it could be WDS?
How to connect to the third router via the second router?
I want to have all networks as one /24 subnet with DHCP server on the main router with enabled Fast Roaming by the Air with one SSID.
The connection scheme is:

connected how ?

cable, or wirelessly ?


well, setting up devices as wireless clients isn't a big deal.

But you probably want at least two radios in the 2nd and 3rd unit,
one for talking to the other router, and one for transmitting the signal
to the clients.

Either use WDS everywhere or use 802.11s mesh. Probably mesh is better for your use case... Otherwise you need to set up an extra WDS AP mode on location 2 and bridge it all together.

1 Like

The main router has a lte wan connection.
How to create a meshed network on OpenWRT?

Here's the wiki:[]=mesh

1 Like

But how to connect mesh points, and connect LAN clients on each router?
I assume I create bridged interface between mesh point (as client) and wlan, ethernet on second and third router.
I have two routers on mt7620 and main router is MT7621AT and all is supporting mesh.

Correct. You create mesh mode stations (which are symmetric no ap/client notion) and then you bridge them to regular APs... treat the mesh as if it were a wire.

1 Like

On main I bridge mesh to LAN like an wlan iface or ethernet port/vlan?

If you want the main device to offer an AP then you bridge: ethernet, mesh, and AP

1 Like

Yes, the mesh node and the local AP would be bridged into the lan network. A dumb AP such as routers 2 and 3 would be has only one network, the lan.

One router is Xiaomi Mi R3 MIR3 with X-WRT port of OpenWRT I figured that the connection to mesh network with wpad-openssl is taking so long after boot... Is there any option to set connecting faster?
I set to the two routers to static ipv4 address instead of dhcp like in wiki.
I set channel from auto to fixed (36) on 5GHz wlan, and it now working without any problems.

Is this option should be disabled on the router which is the main mesh point router?

I enabled Forward mesh peer traffic on the second and third.

It seems like forward should be on all devices. It might work without because of your particular arrangement but I don't see a reason to disable it.

The mesh is working great.
I have Xiaomi 6X/A2 Lite, and I noticed dropdowns on transmission (like video on Facebook) with WiFi connected when I'm going from Main to the second (Jadalnia) and third (Ogrod) router.
I have one SSID for 2.4 on 1,6,11 channel, and 5GHz all connected with mesh on 36 channel with Fast Roaming which works. The transmission between second, third and first is about 120-150 Mbit/s with iperf3.

  1. But on 2.4 and 5 GHz both I set the DTIM Interval to 3, it should be a problem?
  2. I have mutual mobility and SSID domain for 2.4 and 5 GHz, is this correctly configured?
  3. How to check the work of Fast Roaming on a device with Android?
  4. Could the problem be that the WLAN of this phone in AC is working only with a max rate of 150 (it is shown in analytics WLAN tools as 150/866 Mbp/s)?
  5. Could someone should give me a hint on how to enable MIMO or AC on Xiaomi Mi A2 Lite because I saw on xda devs speedtest around 250 Mbit/s?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.