The "server" option in dnsmasq does not take

root@OpenWrt:~# uci show dhcp|grep

I double checked and it's committed to /etc/config/dhcp too.

This didn't seem to work when querying I added log-queries and log-facility to /etc/dnsmasq.conf , did a service dnsmasq restart and it confirmed: it didn't send to But why?

Matching of domains is normally done on complete labels, so / matches and but NOT


Two problems.

One, despite uci adds the config to /etc/config/dhcp the dnsmasq file generated doesn't contain the server option. Is this a bug? I think it is. The wiki lists server as a known option.

Two, when I moved it to /etc/dnsmasq.conf it didn't work because "possible DNS-rebind attack detected". Adding rebind-domain-ok="" helped and now it works.

You must add those entries as a list, not an option:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.