The opkg update command failed with code 6

The opkg update command failed with code 6.

There are 5,980,654,921 threads on this yet none seem to work. Without ability to do any customization through OpenWRT, it's just a like a stock firmware. I will declare it is the best of the worst.

Are you seeking assistance?

(If so, you may want to provide some configuration details/information. Also, if you're truly all default configs as you note, at least describe how you're connected to the Internet.)

1 Like

I'm with @lleachii here: how are you connected to the internet. To take a stab in the dark: the router did't get a DNS server via DHCP or you didn't define one when you are not getting an IP via DHCP.

Goto: "Network" -> "Diagnostis" and see if you can ping anything like "" or "". Most likely that will fail as well because of what I said above.


ping succeeded, and another 4 hours wasted reading threads on how to solve this

Provide adequate info, or keep fumbling in the dark...

1 Like



Feel free to simply provide information or inquire here for assistance - after all, you created this thread.

Frustration is normal when things don't work the way you expect, but we can't really help you without specifics....

Posting your configuration (details below) and a description (or a diagram if the topology isn't simple) of the method of connection of this router to the internet would be a bare minimum for us to be able to assist.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
1 Like

I have just had this error and it was caused by the routers time not being correct. You can correct this under System/system, General settings, set your timezone and click Sync with NTP server.


I just changed the two name servers in /etc/config/wireless from and to that I found in my dsl-router configuration . I did it in the configuration of my WLAN Adapter on my laptop too, for shure.
Now opkg list update runs without any problems
Greetings from Austria

solved in this way. If someone's internet connection has no problem but suffers with code 6, then sync system's time.