The OpenWrt Firmware Selector

Appears to be an issue with ASU.

The build queue is moving forward again. Pos. 317

1 Like

It will take hours of unnecessary work to build images that nobody waiting on

it works again!

1 Like

Mostly. I was able to build snapshot images for two ipq806x, one ipq807x, one ramips and one mediatek target. I have got to consolidate my inventory! But that is a different issue. I'm getting an error building for my Nano Pi's (an R4S and R2S):

Firmware Selector Error Excerpt
Signature check passed.
Updated list of available packages in /home/aparcar/asu/worker1/cache/SNAPSHOT/rockchip/armv8/build_dir/target-aarch64_generic_musl/root-rockchip/../../../../../../../../../../../home/aparcar/asu/worker1/cache/SNAPSHOT/rockchip/armv8/dl/openwrt_telephony
Signature check passed.
Downloading file:packages/Packages
Updated list of available packages in /home/aparcar/asu/worker1/cache/SNAPSHOT/rockchip/armv8/build_dir/target-aarch64_generic_musl/root-rockchip/../../../../../../../../../../../home/aparcar/asu/worker1/cache/SNAPSHOT/rockchip/armv8/dl/imagebuilder
Downloading file:packages/Packages.sig
Signature check failed.
Remove wrong Signature file.
Collected errors:
 * pkg_hash_check_unresolved: cannot find dependency openssl-util for openvpn-easy-rsa
 * pkg_hash_fetch_best_installation_candidate: Packages for openvpn-easy-rsa found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package openvpn-easy-rsa.
make[2]: *** [Makefile:185: package_install] Error 255
make[1]: *** [Makefile:150: _call_manifest] Error 2
make: *** [Makefile:269: manifest] Error 2`

A signature check fails for something in /home/@aparcar and coming up bupkis. Also looks like I may have some investigation to do on new dependencies for openvpn-easy-rsa on rockchip.

Update: working for R2S and R4S now without proceeding error.

@aparcar now added a field that let the user add a script to custom images:

This script e.g. would automatically enable and configure the WiFi:

# WiFi password (at least 8 characters)
# WiFi name

wifi_enable_device() {
  local cfg="$1"
  uci set wireless.$cfg.disabled='0'

wifi_setup_interface() {
  local cfg="$1"
  uci set wireless.$cfg.ssid="$ssid"
  uci set wireless.$cfg.key="$key"
  uci set wireless.$cfg.encryption="psk2"

config_load wireless
config_foreach wifi_enable_device wifi-device
config_foreach wifi_setup_interface wifi-iface
uci commit wireless

The script will be placed in /etc/uci-defaults/ of the image, executed on first boot and then deleted. More information can be found in the OpenWrt documentation.

EDIT: the firmware selector now fills in a script like this on an icon click (gear icon in the right coner).


@aparcar - thank you!

1 Like

Have you tried updating the OpenWrt version with Attended Sysupgrade and see if it still has the script after reset?

I have not tested that.

Firmware selector seems to be broken atm .
Unsupported package(s): nftables
and wont build without it anyway

Almost all packages are broken right now on snapshot. It happens, might take a day or two. You can see the faillogs here, just pick your target: []

edit: looks like most packages are back

1 Like

why i can't find model Orange Pi R1 Plus LTS in firmware-selector web?

pls make support on web for orange pi r1 plus lts.


@sarangnet There are no OpenWrt images for the "Orange Pi R1 Plus LTS" (yet?). That is why it does not appear in the firmware selector.

Custom build seems to be broken for Buffalo Wzr600-dhp2 (bcm53xx). Firmware-selector apparently builds images correctly but there is no link to builds. Tried snapshot and last stable releases down to 22.03.0, also tried adding just one package (nano) in case I requested too many.
Building 21.02.5 with nano package outputs:
"WARNING: maxlen exceeds default maximum! Beware of overwriting nvram!
os-image partition too big (more than 2097152 bytes): Success"
Device's flash size is 128 MiB, I don't know about firmware layout but it should be more than enough or am I wrong?

but why is it available in immortalwrt? and here no? is there a big difference? @mwarning

Well, I didn't know about immortalwrt.. anyway I tested it and just adding one package I get the same error, so maybe it's not possible to create custom builds with this model and I don't remember if I ever downloaded one before.
Indeed @mwarning could shed some light into this, thanks.
Edit: I didn't notice before, there's no sysupgrade image either, only factory. My device already is running openwrt, I should check which one but an old one for sure.

immortalwrt is an OpenWrt fork. Nobody ported support for that device to OpenWrt. I do not know why nobody did that or how hard that is. Sorry.

I added luci as package for the WZR-600DHP2 and it worked. I got a link to the image and have not seen any warning.

I cannot download any custom package build for Wzr600-dhp2. I also tried from different connection/devices/browsers.
Is it just me?
Just for a test I tried downloading 22.03.2 custom firmware for Linksys WRT1900ACS v2 and it works fine, generating kernel, factory and system upgrade images.

Ok so I downloaded imagebuilder 22.03.2 for my device, ran it on pc and it correctly built a custom image. I could not do that from website.