The MAC address random generation function of openwrt version 23.05 does not work in the 'client' mode of the wireless network

The new version of openwrt 23.05 system adds the function of randomly generating MAC addresses in the advanced settings of the wireless network. This function is great. However, during the use, I found that the function of randomly generating MAC addresses can only be used in master mode, but not in 'client' mode. Moreover, I tried to fill in the MAC address myself, but it still cannot be modified. The displayed MAC address is always Is the driver's default MAC address. I don’t know if anyone has encountered such a problem and how to solve it.

The same problem mentioned above exists when I tested it on R8000 and R6220 devices. I also tested it on Raspberry Pi 3B+ device and could not change the MAC address normally.

client to what ?

It is hoped that the function of randomly generating MAC addresses can also be used normally in client mode.

that's fine, but what's on the other end of the client ?

1 Like

I use a wireless client mode relay to bridge to another non-openwrt system router to expand the network.

it's no corporate or even hotel network, etc, where they could be blocking randomized MACs ?

1 Like

Now I can surf the Internet normally and browse Google and other websites when connected to the public network, but the MAC address cannot be modified. After I tried to use wireless client mode to relay to connect to a personal router with the same version of openwrt 23.05 system installed, I found that the MAC address still cannot be modified,only the driver’s default MAC address is displayed. To check whether the MAC address is modified successfully, I check the MAC address shown in the figure below. If the MAC address is modified successfully, the MAC address marked in the figure below will also change.

The picture below is the master mode

The wireless advanced settings in both modes are set to 'randomly generate' the MAC address.
Sorry, new users can only send one image at a time.

That is the MAC of the AP that you are connected to. The MAC being transmitted by your radio can be seen in Network-Interfaces. I tested on a RT3200 and Random does work.

Note that the R8000 and Raspberry Pi use Broadcom chips and their limited free drivers, which often don't support all wireless options.

1 Like

But the same is true for me on MTK platforms such as R6220 and XIAOMI R3G. In client mode, randomly generated MAC addresses cannot be used, but in master mode, MAC addresses can be randomly generated normally.

In addition, the MAC address of the connected AP is not the MAC address in the screenshot. This MAC address is the original MAC address of the R8000 router interface.

I'm primarily a CLI user so I would run iw dev in the CLI to see the station's own MAC. iwinfo <name> assoc shows the MAC of the connected AP.

Of course the only way to really be sure what your radio is transmitting would be to monitor packets on the air with a third device.

Run iw dev in the terminal (TTYD). The 'phy#1' displayed is still the MAC address of the original machine, and 'phy#0' is a randomly generated MAC address.

My test was to have the only radio interface being one STA, which was set to random MAC. Try repeating that. Perhaps the problem is that it only works on one interface.

Of course you need to set each AP or STA to random separately.

I tried to change the randomly generated MAC address in master mode to the driver default, and then left the randomly generated MAC address in client mode unchanged. After restarting the router, the MAC address is still the MAC address of the original machine and cannot be changed. Manually entering the MAC address using customization cannot be modified. However, in version 22.03 of openwrt, you can customize the MAC address and modify it successfully. And both master mode and client mode can be modified successfully, but it has been unable to be modified since openwrt23.05. Whether it is 23.05.0 or the latest 23.05.02, the MAC address cannot be modified in client mode.

I currently have only one bridged AP, and the picture below is the settings page.