Tftp stock firmware on redmi ac2100

Thank you very much for all the OpenWrt work!
I tried to install OW on my ac2100. Managed to copy the 2 files to kernel etc, but in the last steps i screwed up and the router is bricked/blocked => no wifi and no connection on it's IP number.
I managed to setup a tftp server and tried some bin files. However no luck. Guess the ac2100 is looking for the specific initial stock firmware and i don't know what this is.
Can somebody help me out?

And you've followed the debricking guide at ?

1 Like

No i have missed that one. I did not rename the bin file to miwifi.bin and will do this.
I confused how to configure DHCP and tftp on my mac. I will google on this, but if you have guidance in advance . .
I just started tftp with:
sudo launchctl load -F /System/Library/LaunchDaemons/tftp.plist, copied the bin file, put router in pxe and connecting with internet cable. Now I understand it is more complicated than that.

MAC, sorry can't help you there, I'm more of an open platform(s) guy :wink:


I have a linux station :wink:
Found this one and see if I repair the ac2100

Well, that's progress right there!

Then you need to set up a DHCP server and tftp server, and connect the Linux station to the router.

1 Like