Temporary connection of two routers for initial setup


Newcomer to OpenWRT here. I have a PlusNet Hub One running 19.07.5, which I am hoping to give to a friend to use with a 4G USB dongle.

The installation went OK and I currently have the Hub One connected to my Draytek router with a fixed IP address. Web and SSH access work OK but to install the required components (using opkg) to talk to the 4G dongle I need to temporarily set up the Hub One to be able to connect to the internet via the Draytek. Anyone have any pointers?


connect PlusNet Hub One WAN to any of the Drayteks LAN port.

Make sure they don't have the same subnet on the LAN side (192.168.1).

Or you could use the wifi to set the Plusnet as a wireless client to the Draytek.

1 Like

The current set up is:
Cat5 patch lead from Hub One LAN port to Draytek LAN port
Draytek IP is, DHCP server running
Hub One IP is (fixed), DHCP server disabled
This PC (used for setup) is

I can SSH from the PC to the Hub One, but the Hub One can't connect to anything outside the 192.168.1.X local network.
If I enter opkg update at the SSH prompt I get "*** Failed to download the package list from http://downloads.openwrt.org/releases/19.07.5/targets/lantiq/xrx200/packages/Packages.gz"
ping openwrt.org results in "ping: bad address 'openwrt.org'" so I'm guessing there is no DNS configured as this is expected to be provided by the WAN connection?

Fixed it :slightly_smiling_face:

Added the Draytek as a default gateway using

route add default gw br-lan

opkg commands all work now.

Presumably once the USB 4G adapter on the Hub One is up and running I need to delete this?

hence the reason to connect LAN->WAN, you wouldn't have had to play around with a lot of settings.

yes, the old def gw can be deleted.

1 Like

OK, a few steps further on and the Hube One is now running standalone with just a wired link to the PC. I'm following this guide

The 4G dongle is an Alcatel L800Z. I've confirmed it works when plugged directly into a PC and I'm able to access its admin page which defaults to The 4G signal is extremely flakey here though, it's expected to be a lot better at my friend's place.

The steps in the guide above to create the new WAN interface all give the expected results.

The guide above recommends changing the router IP address so as not to conflict with the default settings of the 4G dongle. I have had real difficulty changing the IP address using LUCI, when I click 'Apply and save' a countdown timer appears which seems to be waiting for some kind of confirmation from the browser, the IP address is then left unchanged. Eventually I made the changes via ssh, made the necessary edits to /etc/config/network followed by a reboot. Router IP is now

The guide hints that I should be able to access the 4G adapter's admin page at, which is the only way of checking signal strength, connection status etc. However this doesn't work, I get 'Unable to connect' in Firefox and ping returns "Destination port unreachable". What else do I need to do to make the admin page visible over the LAN?

The LAN IP change waits for 2nd confirmation.
Otherwise, the change(s) are rolled back.

Can you telnet 80 from the router?

Does the wan interface get a DHCP address from the dongle? That should install a route to via usb0 and also make the dongle the default route to the Internet (which of course will not work if the LTE signal is bad).

Can you telnet 80 from the router?

Telnet doesn't seem to be installed. I get "-ash: telnet: not found".

Does the wan interface get a DHCP address from the dongle? That should install a route to via usb0 and also make the dongle the default route to the Internet (which of course will not work if the LTE signal is bad).

On the LUCI page under Network -> Interfaces I see the dongle has assigned the router an IP of, so yes to your first question. I'm not sure how to view the routes (learning Linux networking as I go :slightly_smiling_face:).

One thing it did recommend in the Wiki guide was, if the 4G is going to be the only WAN connection, to delete the other entries from /etc/config/network. I just appended the USB entry to the existing ones, so that's something to try after making a copy of the existing file.

Well that does seem to have fixed it. I can now get to the admin page of the dongle and, on the rare occasions when the adapter shows a green light, bring up the Google home page. Result!

I'm still keen to learn how multiple WANs with fail-over work though, I would like to get a similar setup working for my own use as a backup for when the DSL fails - the 4G adapter will need a big directional antenna to stand any chance of working here though!

so install it ?


@Red-n-Black, welcome to the community!

Telnet has not been used for many versions of OpenWrt.

@Red-n-Black, OpenWrt 19.07.5 uses SSH.