Teltonika RUT955 - modem not detected

@daniel It seems you know your way around the RUT955. Can you help me pleeeease?:slight_smile:

I tested some more uqmi commands but really, --get-signal-info is the only one which gives any positive feedback. all the other commands don't give a reply or give errors...

@sajonasra I'm not sure if I ever tried with a PIN code set. To exclude PIN-code related modem quirks, try disabling PIN entirely using another device (cellphone) and remove the PIN option from UCI. If that works, we at least know where to dig...

1 Like

Hey daniel,
thanks for the info. so, PIN switched off. I took out the SIM from UCI, meaning that I deleted the entry.
Or is there any other way I have to deactivate it?
The reaction of the router is "Call failed".

Probably you are hit by a bug which was fixed recently by

Please retry with more recent snapshot, that may fix it.

1 Like

I tried to use the most recent firmwares:

both firmwares showed the same problems :thinking:

Wild guess: May be, you have to explicitly select the SIM1 (or 2) ?

Just for a try: Use PPP instead of QMI, to verify overall operation. I only use PPP (3g-wwan) on my RUT955. Without PIN, though.

Hi,

I took over the problem from my colleague sajonasra.

The following patch fixes the problem for us:

--- /rom/lib/netifd/proto/qmi.sh        2021-06-15 10:48:20.000000000 +0000
+++ /lib/netifd/proto/qmi.sh    2021-06-16 10:42:19.000000000 +0000
@@ -81,6 +81,10 @@

        echo "Waiting for SIM initialization"
        local uninitialized_timeout=0
+
+       # Reset modem, workaround for a buggy modem after an reboot
+       uqmi -s -d "$device" --set-device-operating-mode reset
+
        while uqmi -s -d "$device" --get-pin-status | grep '"UIM uninitialized"' > /dev/null; do
                [ -e "$device" ] || return 1
                if [ "$uninitialized_timeout" -lt "$timeout" -o "$timeout" = "0" ]; then

Feel free to submit an official patch, or ask a developer to do so. As this seems to be a reasonable precaution, anyway. (Which I always fiddle myself using AT-cmd for the PPP-connection via EC25).

Hi, there.. I need help.

How do I get the Modem Running? Do I need to change the GPIO Pins in /etc/board.d/03_gpio_switches ? If I do that, dmesg says : export_store: invalid GPIO 44 export_store: invalid GPIO 45 export_store: invalid GPIO 33

Or what about the mx880 Script?

Using RUT955 myself, with EC25. Running very well, both in USA and in Germany and in Bulgaria. Using recent openwrt, custom built.

Assuming, you also have an EC25, make shure, it is the correct subversion, depending upon your location.
And flash newest firmware to the EC25.
Finally: Which version of openwrt, are you using PPP or QMI ?

There are two (quite different) version of the RUT955, both with EC25 modem, and what you are describing sounds like you have flashed the wrong image for the hardware you got.
older: teltonika_rut955-h7v3c0 => need screwdriver to open case in order to access SIM cards
newer: teltonika_rut955 => sim card slots accessible from outside, comes with metal pin to drag them out.

I have the one with the Metal Pin opener.

My location is germany / Europe

Location is not important.
Which version of OpenWrt did you flash? And which exact image file did you use?

Hi, I used this:
https://downloads.openwrt.org/releases/21.02.2/targets/ath79/generic/openwrt-21.02.2-ath79-generic-teltonika_rut955-squashfs-factory.bin

from:

This looks like the correct image for that version of the device. Please share output of logread after boot and also content of /etc/config/network so we can see what's going on there.

Sat Mar  5 09:05:28 2022 user.notice ModemManager: hotplug: cached event found: action=add, name=ttyS13, subsystem=tty, sysfspath=/sys/devices/platform/serial8250/tty/ttyS13
Sat Mar  5 09:05:28 2022 user.notice ModemManager: hotplug: event reported: action=add, name=ttyS13, subsystem=tty
Sat Mar  5 09:05:28 2022 authpriv.notice dropbear[3300]: Auth succeeded with blank password for 'root' from 192.168.6.10:55188
Sat Mar  5 09:05:28 2022 user.notice ModemManager: hotplug: error: parent device sysfspath not found
Sat Mar  5 09:05:29 2022 user.notice ModemManager: hotplug: cached event found: action=add, name=ttyATH1, subsystem=tty, sysfspath=/sys/devices/platform/ahb/ahb:apb/18500000.uart/tty/ttyATH1
Sat Mar  5 09:05:29 2022 user.notice ModemManager: hotplug: event reported: action=add, name=ttyATH1, subsystem=tty
Sat Mar  5 09:05:29 2022 user.notice ModemManager: hotplug: error: parent device sysfspath not found
Sat Mar  5 09:05:29 2022 user.notice ModemManager: hotplug: cached event found: action=add, name=ttyACM0, subsystem=tty, sysfspath=/sys/devices/platform/ahb/1b000000.usb/usb1/1-1/1-1.3/1-1.3:1.0/tty/ttyACM0
Sat Mar  5 09:05:29 2022 user.notice ModemManager: hotplug: event reported: action=add, name=ttyACM0, subsystem=tty
Sat Mar  5 09:05:29 2022 user.notice ModemManager: hotplug: no need to wait for modem at sysfs path /sys/devices/platform/ahb/1b000000.usb/usb1/1-1/1-1.3
Sat Mar  5 09:05:29 2022 user.notice ModemManager: hotplug: cached event found: action=add, name=wlan0, subsystem=net, sysfspath=/sys/devices/platform/ahb/18100000.wmac/net/wlan0
Sat Mar  5 09:05:29 2022 user.notice ModemManager: hotplug: event reported: action=add, name=wlan0, subsystem=net
Sat Mar  5 09:05:30 2022 user.notice ModemManager: hotplug: error: parent device sysfspath not found
Sat Mar  5 09:05:30 2022 user.notice ModemManager: hotplug: cached event found: action=add, name=br-lan, subsystem=net, sysfspath=/sys/devices/virtual/net/br-lan
Sat Mar  5 09:05:30 2022 user.notice ModemManager: hotplug: event reported: action=add, name=br-lan, subsystem=net
Sat Mar  5 09:05:30 2022 user.notice ModemManager: hotplug: error: parent device sysfspath not found
Sat Mar  5 09:05:30 2022 user.notice ModemManager: hotplug: cached event found: action=add, name=eth0.1, subsystem=net, sysfspath=/sys/devices/virtual/net/eth0.1
Sat Mar  5 09:05:30 2022 user.notice ModemManager: hotplug: event reported: action=add, name=eth0.1, subsystem=net
Sat Mar  5 09:05:30 2022 user.notice ModemManager: hotplug: error: parent device sysfspath not found
Sat Mar  5 09:05:32 2022 daemon.info [2088]: <info>  [base-manager] couldn't check support for device '/sys/devices/platform/ahb/1b000000.usb/usb1/1-1/1-1.3': not supported by any plugin
Sat Mar  5 09:05:32 2022 daemon.info [2088]: <info>  [base-manager] couldn't check support for device '/sys/devices/platform/ahb/18100000.wmac': not supported by any plugin
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd29:1926:9297::/48'

config interface 'wwan0'
	option mode 'preferlte'
	option proto 'ncm'
	option device '/dev/ttyUSB1'
	option pdptype 'IP'
	option ipv6 'auto'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.6.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 0t'

The wwan0 is created my myself, because of the post here before.

This looks a bit wrong. Afaik ttyUSB1 is the GPS interface. Where did you copy that config from? I guess it's better you just use the LuCI frontends for either uqmi or modemmanager to create the config, as in that way you will end up with a working configuration.

Yes, I have copied that..

Modemmanager oder QMi does not have an Modem device.. The Field ist empty.

Ok, so probably the modem is not powered on for some reason, and that could be because you got yet another newer version of the device sold under the same name.
Please share the output of dmesg so we can know more...