Telekom With 7530 Openwrt

Hello there,

im totaly new to this and try to get this working with tutorials ,but i stuck and may ask you pro´s.
i installed openwrt on 7530 which has a modem includet and try to connect to VDSL Telekom.

these are the configs i placed so far ,

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd6c:7d88:b451::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '0 4 3 2 1'

config dsl 'dsl'
option annex 'b'
option tone 'bv'
option xfer_mode 'ptm'

config interface 'wan'
option proto 'pppoe'
option _orig_ifname 'ptm0'
option _orig_bridge 'false'
option username '*********@t-online.de'
option password '
'
option ipv6 'auto'
option device 'eth0.7'

config device
option name 'eth0'

config device
option name 'eth0.1'
option type '8021q'
option ifname 'eth0'
option vid '1'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t'
option vid '7'

config device
option name 'eth0.7'
option type '8021q'
option ifname 'eth0'
option vid '7'

any ideas or steps which i made wrong?
thanks

First:

Just make sure you "sandwich" your text between two rows of backtick characters ` (which themselves will be invisible in the preview) looking in something like this in the editor:
```
Your Pasted Text as preformatted text with fixed width font
1
1111 (note with fixed-width fonts the numbers are right-aligned)
```
but looking like this in the rendered forum:

Your Pasted Text as preformatted text with fixed width font
   1
1111 (note with fixed-width fonts the numbers are right-aligned)

Then you need to:
A) follow the instructions here to install OpenWrt in a way that supports the modem:

Which notes:
"The integrated VRX518 DSL modem is only supported in snapshot and releases from 23.x onwards. It does not work on 22.03.x and earlier." This uses DSA so all the switch statements in your config are wrong.

So:
A) install the necessary OpenWrt snapshot
B) manually install the required firmware blobs
C) configure wan to use dsl0.7 and PPPoE

thanks!,

after all that, how does the config should look like?
should i configure wan with dsl0.7 as device and pppoe seperatly?
and what about the switch settings?

I can not really tell you, as I use my 7520 as bridged modem (running an OpenWrt snapshot from March). But I should have an older config as full router somewhere... let me search for that later...

EDIT: Mmmh, my only "as router" config predates DSA and hence is not going to be all that useful, but @elder_tinkerer already "saved the day"...

Hi,
this is my working configuration.

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd48:xxxx:xxxx::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'j'
        option tone 'b'
        option ds_snr_offset '0'
        option firmware '/lib/firmware/xcpe_8D1507_8D0901.bin'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '192.168.1.1/24'

config device
        option name 'dsl0'
        option macaddr '12:34:56:78:90:AB'

config interface 'wan'
        option proto 'pppoe'
        option ipv6 'auto'
        option password 'xxxxxxxx'
        option username 'xxxxxxxxxxxxxxxxxxxx#0001@t-online.de'
        option device 'dsl0.7'

config interface 'wan6'
        option device '@wan'
        option proto 'dhcpv6'
1 Like