Telekom Germany VLAN Tag

Hey guys, i am tying to install OpenWrt. Unfortunately I cannot connect to my ISP. As described in the Wiki i tryed to Tag my WAN with VLAN7.

Here is my /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde3:bb55:5608::/48'

config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
        option annex 'b'
        option firmware '/lib/firmware/adsl.bin'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'dsl0.7'
        option proto 'pppoe'
        option ipv6 '1'
        option username '"ID"#0001@t-online.de'
        option password '"password"'

config interface 'wan6'
        option ifname '@wan'
        option proto 'dhcpv6'

config switch                
        option name 'switch0'
        option reset '1'                               
        option enable_vlan '1'    
                            
config switch_vlan           
        option device 'switch0'                        
        option vlan '1'           
        option ports '2 3 4 5 0t'
                       
config switch_vlan             
        option device 'switch0'
        option vlan '2'          
        option vid '7'
        option ports '0t 6t'

What is wrong there:/

which device?
which openwrt version?
any messages regarding pppd or dsl-firmware in syslog?

1 Like

With an external modem, WAN configuration should be eth0.7 not dsl0.7. With internal modem (not attached by Ethernet) you don't need to have a vlan 7 in the ethernet switch.

Also remove the default dhcp6 wan6, all your wan v4 or v6 will be through pppoe.

A proto pppoe interface will spawn another interface pppoe-wan which is the endpoint of the ppp tunnel. You generally don't have to interact with that directly.

1 Like

Hey fuller, it is this device https://openwrt.org/toh/astoria/arv752dpw22.
If i search in the logs i cant find logs of ppp or the dsl-firmware.

I tryed two versions: once openwrt 18 and lede 17

The modem is internal. I removed dhcp6 and wan6.

As i found on this website: (https://telekomhilft.telekom.de/t5/Telefonie-Internet/Wie-OpenWRT-Router-am-FTTH-Anschluss-betreiben/m-p/2967765/highlight/true#M868204) the user should be written like this:

Anschlusskennung#Zugangsnummer#Mitbenutzernummer@t-online.de

It not connecting to the isp and i have no idea how to debug this:(

New URL: https://openwrt.org/toh/astoria/arv752dpw22

The old page is for archival purposes only and doesn't receive any updates any more.