TD-W8970b dsl still be down

Hello there,

I recently installed OpenWrt 19.07 on my tp-link TD-W8970b, eberything went smooth and then I tried to set-up the dsl, as I switched from adsl to vdsl. After checking with my isp, the only settings I need are PPPoE, vland id, annex b and username and password. But after everything was set-up, I still only see link down and no device in iterfaces.
Suppory from isp confirmed, that they do not see my router, and of course pointed to the fact, that the router is not vdsl compatible, but we know better :wink:
I tried different settings for annexes, at no avail.
Can anyone help me?

Are you on a vectoring line? The default modem firmware that comes with OpenWrt does not do vectoring, you would have to install a custom firmware file for that.

Even then, the line should show some kind of activity and (although I have never experienced that) it should even connect to a non-vectoring fallback. Are you sure "everything went smoothly" and the line is actually connected? (I am, unfortunately, speaking of own experience.)

1 Like

Can you post your network config?

Hello takimata, yes, everything went well regarding the installation.
Unfortunately I can see link as down at all time, isp cannot see my router connected.
How and what kind of vdsl firmware should I use? Do I need to flash it, or just a give a shortcut in specific settings folder?
Btw. Isp is leased Telekom.from.Slovakia, I thik it should be similar to german Telekom.
What I know, I need to be on Annex B, set-up the vlan id, in this case 2510, username, password and Ppppoe, and everything should work, but it won't. :frowning:

Did you test the line with another vdsl router to eliminate any external factors and to make sure that you have no cabling problems?
If you tested the line with another router and the line is fine then you should post your network config file contents and you system log here so we can see what's going on and help you.

Today was the link tested with known working router. Unfortunately the owner of the working router couldn't remember his settings, so we couldn't change it to mine, and as he is with another isp, no dsl light came up. As I do not know the proper behavior of the dsl light, if it will flash or blinks on connection with user and password missmatch, or if it will stay off, I cannot say if the link is alive or not.

PPPoE authentication comes after the line sync, so dsl light should be on and stable before authentication and even if it fails the line stays on.
Check your connection form the box to make sure nothing is disconnected if you can't seen anything wrong with your line, open a ticket with your service provider.

OK, so if the working router wont show any activity on the line, dsl led stays off, the line is down. Here is my network settings:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd6d:9ad9:a6c9::/48'

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0.1'
	option macaddr 'c4:6e:1f:6e:a9:40'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 2 4 5 6t'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option nameprefix 'dsl'
	option payload 'bridged'

config interface 'wan'
	option proto 'pppoe'
	option macaddr 'c4:6e:1f:6e:a9:41'
	option ifname 'ptm0.2510'
	option username 'xxx@slovanet.adsl'
	option password 'xxxxxxx'
	option ipv6 'auto'
	option mtu '1492'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config dsl 'dsl'
	option firmware '/lib/firmware/vdsl.bin'
	option line_mode 'vdsl'
	option ds_snr_offset '0'
	option annex 'b2p'

This needs to be dsl0.2510 on recent OpenWrt versions.

That is the problem. Not any of the other settings. If neither your router, nor another router ever shows up a synchronized line, and the ISP can't see anything at your end, the line itself is at fault.

Again, I speak from experience. Last time I changed an ADSL to a VDSL line, it was connected wrong. It happens. You need to contact your ISP and have the line checked.

Alright then, I will do so. Btw, has anyone dsl.bin image that supports vectoring, annex B for sharing?
Thank you

I'd also suggest that you try with line_mode 'auto' and annex 'b' . If your Annex and Line mode settings are wrong then DSL stays down and never syncs (at least for me).

@aupnxabs I tried this, but get stuck at make menuconfig with umask 0022 error. tried different live distros, outcome still be the same.
Therefor I was asked, if somebody has already done that and can share the *.bin file. :wink:

@ahmar16 tried all kinds of settings, this one was the first, the line still be down.

Just open a ticket with your service provider and let them solve the line problems for you.
And when it's solved you can worry about vectoring which won't prevent the line from syncing.
Vectoring will just help the line to sync at a higher rate.
Check this site for different Annexes and Vectoring.
https://xdarklight.github.io/lantiq-xdsl-firmware-info/

Hello guys, thank you all for your help. the problem was in me not following the procedures tight enough. In DSL setting in Luci I had reference to vdsl.bin firmware, but no such firmware was present. So I laboured with differnt kinds of firmwares, and then uploaded them one after another to the router. Once the reference was correctly set-up, the link immediately showed up and connected.
Another thing is, that with 3 different firmwares, the speeds were the same, means 52,5Mbits download, 5,3Mbits upload. Ordered was 80/8Mbits program, so I raised a ticket at the ISP.
So once again BIG THANX to everyone, and sorry for my stupididy. :frowning:

It's always a safe bet to keep a regular router with no 3rd party firmware on hand just to rule out any problems that might be caused by 3rd party firmware, like in your case.
Not to mention that most ISPs if not all don't approve nor support any routers with 3rd party firmware and tend to blame it for any problem that might arise.
Get the cheapest VDSL router you can find even a used one will do and see if you get the same speeds with it as the ones you get with your TD-W8970b and go from there.