TD-W8960N how to install OpenWrt? TELNET installation Issue

I have a (very old, I know) TD-W8960N V4, but I can't seem to find how to upgrade it to OpenWRT.

I connect to the router with telnet... I tried using OpenWRT and Lede images for this router... but I ALWAYS get the error "illegal image".

Any help?

Copying and pasting the Wiki of the device? Nice reply.

I've done what the Wiki asks for installation. I've connected to the device via 'telnet' and used my TFTP server to send the image. I got the "illegal image" error.

@matbarni - many users don't even look at the device info page, so it is the first response that will often be posted.

That said, I don't know that you'll really want to use this particular router with OpenWrt because 1) it is really old and relatively resource constrained, and 2) the wifi drivers are not good due to the closed-source nature of the broadcomm chipset. If you're using this as an AP at all, you'll probably be unhappy. But if you're using it to learn OpenWrt or as a low-bandwidth device for some other purpose, you might be okay.

With respect to the efforts to flash this device, did you follow the procedure exactly as written (including renaming the file and using the arguments in the tftp command)?

1 Like

Yes I did follow the Wiki accurately.

I started a TFTP server. I have the image there.
I connected to the device via Telnet.
I send the file via Telnet using the TFTP server as the file provider, the file is LOCATED in the server AND IS SENT.
After that, I get the "illegal image" error in Telnet from the device.

I've tried 4 different images, from 2 old LEDE builds to the device and newer OpenWRT builds (4mb and 8mb files were tried).

Pushing the "original" TP-Link firmware works.

The device is old, yes. Everything that is electornics is extremely expensive where I live. A simple router that is newer and has 5 gigabit ports is 50+ dollars. That is a week of my paycheck.

You may be able to find devices for much cheaper that have good support with OpenWrt. However, I'm not necessarily suggesting that you spend more money here -- my point was that the performance of the router will likely be much worse than the TP-Link factory firmware -- wifi doesn't really work, the DSL modem also doesn't work at all with OpenWrt. So if either of those features are important for your use, you should not flash OpenWrt. You might actually check to see if DD-WRT supports this router -- this is one of the few situations where DD-WRT may be a better option all around.

Also, see this old thread -- the V4 hardware at the time didn't appear to be working at all. Some searching of the archive forums may turn up some additional installation/troubleshooting info (and/or warnings about it not working).

1 Like

I understand that. I read a lot about the device. It seems V4 has some issues but there are many people that also says it works.

If the device is really not supported anymore... Or if all the old build were never supported, than how do I change the Wiki page to remove V4?

I don't need performance at all from the device. I need to study VLANs with it... once I know what I am doing and have saved some money, I would buy a newer device.

I don't have the device you are using, so I can't offer any specifics about what might be going wrong with the flashing process. I would suggest, though, that you try using each of the available firmware versions from TP-Link as your starting point -- sometimes a change to the firmware affects the type of image (or validation process) required to deem a file valid for flashing. And start with the LEDE image that is referenced in the device info page -- once you can get the device running LEDE, you can easily upgrade to OpenWrt 18.06 or 19.07.

1 Like

It's not possible to downgrade the original firmware, so I can't go to older versions that validade the '.bin' in a different way.

V4 does NOT work. Or at least the Wiki should say "JTAG flash" only.

Serial console, the second installation method, would likely work.

Check if there is a CFE web recovery. Many CFE bootloaders have a recovery web page at if you turn the power on with the reset button held down until the LEDs start blinking a different way. There is no DHCP server in recovery mode so you will need to static IP the PC.


This suggests that TP-Link did indeed change something about the way the firmware is verified -- file format, encryption/signing, or some other technique. This could very well be the reason you are unable to get the system to accept the LEDE/OpenWrt image.

As @mk24 said, serial console or CFE web recovery may well work. It is certainly worth a try.

1 Like

@mk24 Thanks for the reply

I tried booting into recovery mode several times ( 30/30/30 + fixed IP in the PC ) and the Router always boot normally, I can't make it boot into CFE.

Is there a better way to make sure I'm doing it correct?

@psherman @mk24

Thanks a lot, specially psherman... But it seems that there is too much hassle into making this happen.

I tried using a Hex Editor in the ".bin" so the beggining of the file should skip validation as per some tutorials, but it did not work.
I am unable to solder stuff to this thing, too little experience with it.

Thank you all anyway, this seems a problem that requires debbuging the bootloader or kernel to see what changed, and unfortunately, I don't have experience on how to do that.