Tailscale subnet

I use TailScale and I can ping the IP of Tailscale clients. But not anymore on their subnet eg 192.168.3.43 on another Linux machine it works fine. So I think there will be a problem somewhere in the Firewall?

When you connect to a VPN, you make a secure connection to the network. You don't access the local subnet while connected.

To solve the problem you can:

  • Disconnect
  • There may be a setting in your software to allow "VPN leaks"

I'm talking about this: https://tailscale.com/kb/1019/subnets/ my raspberry can see the whole network on the other side of town. On OpenWrt, it only sees the main IP of the Tailscale device. But I need to see u to the intranet on the other side of town. I believe it must go. Sorry for my English.

You will need to provide more details of your setup.

I also tried this via ssh: route add -host 192.168.66.1 dev tailscale0 but that didn't work either.

I think the issue is you need to tell OpenWrt that there is a network on the other side of the tailscale endpoint. you want something like:

ip route add 192.168.3.0/24 dev tailscale0

Unfortunately, that didn't work either. I have no idea where the problem could be.
Bez názvu

LOG:
Thu Oct 27 17:46:46 2022 daemon.err tailscaled[6121]: 2022/10/27 17:46:46 Accept: ICMPv4{100.110.129.11:0 > 192.168.1.43:0} 84 ok out
Thu Oct 27 17:46:47 2022 daemon.err tailscaled[6121]: 2022/10/27 17:46:47 Accept: ICMPv4{100.110.129.11:0 > 192.168.1.43:0} 84 ok out

what network is the LAN on? you can't have 192.168.1.0/24 in multiple places.

my LAN is 192.168.3.0/24, you can see it in the picture.

Ping to some Tailscale IP address log is different that it is TCP and not ICMPv4 could this be the problem?

Fri Oct 28 10:45:56 2022 daemon.err tailscaled[2857]: 2022/10/28 10:45:56 Accept: TCP{100.71.176.10:54906 > 100.110.129.11:22} 52 tcp non-syn

So I solved it. It was necessary to disable Tailscale to create IpTables rules that OpenWrt 22.03 could no longer deal with. Maybe create your own with NfTables. Now it works as it should.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.