Tailscale on extroot problem?

I had my tailscale subnet working. But I think there is some issue with the extroot.

It was working but then I reboot and try to start tailscale I get

# Health check:
#     - router: adding [-m mark --mark 0x40000 -j MASQUERADE] in v4/nat/ts-postrouting: running [/usr/sbin/iptables -t nat -A ts-postrouting -m mark --mark 0x40000 -j MASQUERADE --wait]: exit status 2: iptables v1.8.7 (nf_tables): Chain 'MASQUERADE' does not exist
Try `iptables -h' or 'iptables --help' for more information.

All of these are present


I backed up:

  1. Am I suppose to start tailscale with /overlay/upper/etc/tailscale start?
  2. Each time do I have to startup with "tailscale up --accept-dns=false --advertise-routes="?
  3. What am I missing?

If it worked before you configured the extroot, and fails after you configured the extroot... looks like something went wrong during the configuration of extroot. Did you copy all the overlay data to the extroot?

Sorry, I didnt explain that correctly. It worked with extroot on. But I think it doesnt save to the extroot or something. I have to reinstall tailscale, delete all previous configurations, to make it work.

Do you have to copy the overlay data manually each time?
I thought the point of the extroot was do be the default storage for new data.

I do not have enough space on the router to test that. I just do not understand what is going on. I am fairly new at all of this.

My extroot was a problem. Still not getting tailscale to work but definitely had issues with extroot separately.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.