Tailscale as exit node - Discussions

I've been testing Tailscale as an exit node on a mini VPN Gateway (Brume 2 GL-MT2500) running the latest snapshot. Seems to work good, having access to my network servers and being covered by AdGuard while traveling is nice (Especially me because I'm behind CGNAT)
I followed this guide:
https://openwrt.org/docs/guide-user/services/vpn/tailscale/start

However, when I advertise subnets and my exit node, I get this warning:

Warning: UDP GRO forwarding is suboptimally configured on eth0, UDP forwarding throughput capability will increase with a configuration change.
See https://tailscale.com/s/ethtool-config-udp-gro

I was reading the info on this link but before I wanted to know what exactly other users did to solve this. And how much this could affect the performance and speeds? (I've tested the exit node using mobile data while traveling, my home bandwidth isn't too high too, so I have no idea about its impact)

It is a job for /etc/rc.local
Find out offendign parameter(s):

ethtool -k eth0 | grep -e rx-gro-list -e rx-udp-gro-forwarding
rx-gro-list: on
rx-udp-gro-forwarding: off

Then in /etc/rc.local before exit0 line:

/usr/sbin/ethtool -K eth0 rx-gro-list off

Run command once for this session and restart tailscale connection, or just reboot to see warning gone.

1 Like

I added this and after a reboot I still see the warning


Now it is off after a reboot though :thinking:

You need to enable other parameter according to tailscale doc....

I’ll try, you managed to get it working?

Like thousands of times?
You can &se startup or hotplug scr)pts to change values to what 3rd party expects.