Tag VLAN Fritzbox4040 and PPPoE issue

Hello everyone, I was trying to install Openwrt on a Fritzbox 4040, the installation was successful but if I try to configure the wan interface with vlan 835 and pppoe with the credentials of my ISP the PPPoE times out. I leave the log for more details.
is it a VLAN problem or something? I leave the config down. Thanks

etc/config/network:

config interface 'wan'
	option ifname 'eth1.835'
	option proto 'pppoe'
	# ISP CREDENTIALS

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 4'

config switch_vlan
	option device 'switch0'
	option vlan '835'
	option vid '835'
	option ports '0t 5t'

I try also with

config device 'waneth4'                                                        
        option type '8021q'                                                
        option name 'waneth1'                                                                      
        option ifname 'eth1'                                             
        option vid '835'                                                   
        option ipv6 '0'                                                        
                                                                           
config interface 'wan'                                                     
        option auto '1'                                                    
        option proto 'pppoe'                                               
        #ISP CREDENTIALS                                             
        option ifname 'waneth4'   

Read this:

Cheers,
Thomas

Ahhh the classic double tagging issue. Try the suggested build, is likely to work according to other's users reports.

So, i need to use Openwrt 18.06, right?

I don't think so. You can use mine which is 20.01