Sysupgrade not possible when model changes?

So I have that very nice small device with build in battery (works as a power bank too) here:

image
Hame MPR-A1

In the past I used this device with the images for the device A5-V11 which has the exact same hardware and specs but only misses the battery. For some reason the A5-V11 was EOL'ed in Version 17.01 while the MPR-A1 only was EOL'ed recently with 19.07.

I just tried to run a sysupgrade with luci but get the following error message:

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

I expect it to because of the model change? Is there anything I could do to run a successful ota update?

You can force the upgrade, whether it's successful or not, is another thing ,)

Probably not within the web interface of 17.01?

I get the error directly when the file is uploaded before I can "choose" anything (only can tick the box to keep settings before)

There's a force in Luci too, not sure if it existed in 17.01 though.

If not, sysupgrade from OS.

SSH in - upload firmware to tmp and run sysupgrade with force argument kind of way?

That's the one.

1 Like

Worked a treat :ok_hand: