System reset and LuCi at 192.168.1.1 connection fail?

Hello!
I actually have two WRT 3200ACM routers (long story with the serial cable) so that is nice when I tries something new like this time when I started up a OpenVPN tunnel which worked at the second attempt on my "test router".

But my problem started when trying to configuring the other "operational router". Both routers has the factory install:
openwrt-18.06.1-mvebu-cortexa9-linksys-wrt3200acm-squashfs-factory.img since 2018/12/17
and updated with:
openwrt-18.06.4-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin since 2019/07/26
They are both configured exactly the same with the same backup config tar.gz file.

Before I was trying to move the config files from the working OVPN "test router" to the "operational router" i made a system reset from LuCi, that worked fine and the "operational router" rebooted. My Win 10 computer got it´s IP address from gateway 192.168.1.1. The internet connection works. But it was impossible to connect to LuCi at both http://192.168.1.1 or https://192.168.1.1. SSH didn't work ether, Serial connection works (both with PuTTY).
It got late in the evening and I got tired and finally made a router CPU switch and the router booted up with the old 18.06.1 software.
Now LuCi worked with my usual old IPv4 172.nnn.n.n LAN address and everything was fine but with the wrong old software.
So I made a software update from LuCi with my original saved openwrt-18.06.4-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin from my HDD in my computer.

Same problem again!? The router reboot, my computer gets a working connection from gateway 192.168.1.1, internet works. But LuCi (Firefox and IE) get connection failure, SSH get access denied.
But serial works so I know for sure the software update worked and the router boots up with 18.06.4.
I tried to install SSL package when connected with serial cable, the installation worked. But the connection doesn't work. Doesn't matter if I use http or https.
I even tried to install luci (only the package that is called luci) with the serial, the installation worked but the connection does not work.

I have a little feeling that the problem lies in Win 10 and that blocks IP 192.168.1.1 so I tried network reset on my computer, that didn't work.
I have also tried a USB LAN dongle, no difference.

I did find some very old forum online about LuCi connection problem that said to empty the cache of the web browser. But if the SSH doesn't work I don't see any point trying that, but I tried on IE but it didn't work.

One thing I notice with every connection attempt is the fail speed! It never even tries to make the call regardless of which program I use to connect, it just pop-up the error, no loading, no testing, no "turning arrow" or noting. Bang, "you are out" exactly when I push the enter button.
LuCi connection usually isn't a high speed thing to say it straight out.

I can connect to my working "test router" with all systems LuCi, SSH, WinSCP and serial so I know they work i general on the Win 10 computer.
The bottom line seems to be that if the router IP address is the standard 192.nnn.n.n instead for example my own 172.nnn.n.n then SSH, LuCi and WinSCP connection fails!?

I have tried to turn of antivirus/security software, no use. But if the problem was there the 172.nnn.n.n wouldn't work ether.

It feels that I now have started to randomly test things without a plan. I kind of got stuck what to do next if I want to run 18.06.4 instead of 18.06.1?

Maybe a change of the router IP address from 192.168.1.1 to the 172.nnn.n.n I know works in the Win 10 computer works but how do I do that from the serial connection?

Be careful as each router has it's own MAC address and possibly SSH keys.
What is the error reported when you try to connect with SSH?
With Luci most likely cleaning cache and cookies might do the trick.

Either directly edit the /etc/config/network or with

uci set network.lan.ipaddr='blah.blah.blah.blah' ; uci commit network; service network reload
2 Likes

Hello,

I have figured out that from now on when I start using OVPN that I will have to manually config the routers side by side and have parallel backup files. It is a little work but it is very nice when these things happens or I want to try new functions without the pressure that it must function the same day.

PuTTY say: "PuTTY Fatal Error, Network error: Permission denied" when trying to SSH connect to 192.168.1.1 on port 22.

I started up my old and slow stone age ASUS Eee PC with Win XP and connected the router, started Firefox and typed in https://192.168.1.1 and LuCi came up!?

It is just as I suspected, the problem is not the router, it is Microsoft and Windows 10.

What is wrong with Microsoft now days? Noting works in Win 10, software stops working when they run updates and setting buttons doesn't matter if I put them in ON or OFF, there are just there for me to feel happy or something because something else is always running the settings regardless of my intentions?

I will try to use the ASUS to config the router and see if Win 10 starts to like it after that?

Ok, to solve this you simply need an very old computer to config the router from the reset values of 192.168.1.1.
Now when I loaded the backup config file in the router offline with the ASUS Eee and Win XP with Firefox everything after that works in LuCi (firefox) and SSH (PuTTY) works in Windows 10. But I use a gateway based on 172.nnn.n.n.